Bug 13522

Summary: Depens on dev packet
Product: [Distributions] Branch 4.0 Reporter: Vyatcheslav Perevalov <vip0@seversk.ru>
Component: expectAssignee: Sergey Bolshakov <sbolshakov@altlinux.org>
Status: CLOSED DUPLICATE QA Contact: Q.A. 4.0 <qa-4.0@altlinux.org>
Severity: normal    
Priority: P2 CC: mike@altlinux.org, vsu@altlinux.org
Version: 4.0   
Hardware: all   
OS: Linux   

Description From 2007-11-25 20:36:47
При установке тащит за собой пакет dev, ныне упразднённый
Steps to Reproduce:
1.apt-get  install expect
Reading Package Lists... Done
Building Dependency Tree... Done
The following extra packages will be installed:
  dev
The following NEW packages will be installed:
  dev expect
0 upgraded, 2 newly installed, 0 removed and 1 not upgraded.
Need to get 0B/1290kB of archives.
After unpacking 314kB of additional disk space will be used.
Do you want to continue? [Y/n] n
Abort.

2.
3.
------- Comment #1 From 2007-11-25 21:13:12 -------
expect зависит от /dev/pts, которую провайдит только пакет dev.
вероятно, нужно попросить предоставлять это и udev.
------- Comment #2 From 2007-11-25 21:15:12 -------
пока можно выставить RPM::Fake-Provides { "/dev/pts"; } в apt.conf
------- Comment #3 From 2007-11-25 22:50:50 -------
См. Bug #12020 - просто добавить Provides: /dev/pts нельзя, иначе udev
потянется
в hasher chroot.
------- Comment #4 From 2007-11-25 23:50:18 -------
Упс, надо было проверить перед тем, как советовать вешать... но вроде такого не
припоминал.

*** This bug has been marked as a duplicate of 12020 ***