Bug 14699

Summary: error: read failed: Is a directory (21)
Product: [Development] Sisyphus Reporter: ildar <ildar@altlinux.org>
Component: aptAssignee: Gleb F-Malinovskiy <glebfm@altlinux.org>
Status: CLOSED DUPLICATE QA Contact: qa-sisyphus@altlinux.org
Severity: minor    
Priority: P2 CC: at@altlinux.org, boyarsh@altlinux.org, evg@altlinux.org, imz@altlinux.org, ldv@altlinux.org
Version: unstable   
Hardware: all   
OS: Linux   

Description From 2008-02-29 08:09:44
Проблема в том, что зачем-то apt читает в текущей папке "файл" rpm. В /etc, в
частности, rpm - это папка, и из-за этого apt сбоит. Вот кусок strace-а:

5223  stat64("rpm", {st_mode=S_IFDIR|0755, st_size=1024, ...}) = 0
5223  stat64("rpm", {st_mode=S_IFDIR|0755, st_size=1024, ...}) = 0
5223  open("rpm", O_RDONLY)             = 9
5223  fcntl64(9, F_SETFD, FD_CLOEXEC)   = 0
5223  gettimeofday({1204259175, 388979}, NULL) = 0
5223  fstat64(9, {st_mode=S_IFDIR|0755, st_size=1024, ...}) = 0
5223  write(1, "\rReading Package Lists... 0%\r", 29) = 29
5223  stat64("rpm", {st_mode=S_IFDIR|0755, st_size=1024, ...}) = 0
5223  stat64("rpm", {st_mode=S_IFDIR|0755, st_size=1024, ...}) = 0
5223  lseek(9, 0, SEEK_SET)             = 0
5223  fstat64(9, {st_mode=S_IFDIR|0755, st_size=1024, ...}) = 0
5223  select(10, [9], NULL, NULL, {1, 0}) = 1 (in [9], left {1, 0})
5223  gettimeofday({1204259175, 390382}, NULL) = 0
5223  read(9, 0xbfe677b8, 96)           = -1 EISDIR (Is a directory)
5223  gettimeofday({1204259175, 390517}, NULL) = 0
5223  write(2, "error: ", 7)            = 7
5223  write(2, "read failed: Is a directory (21)"..., 33) = 33

Steps to Reproduce:
1. cd /etc
2. apt-get install

Actual Results:  
error: read failed: Is a directory (21)
Reading Package Lists... Error!
E: Failed reading file rpm
E: Problem opening
/var/lib/apt/lists/_mnt_nfs_media_ALTLinux_repo_._base_pkglist.local
E: The package lists or status file could not be parsed or opened.
------- Comment #1 From 2008-06-05 12:35:54 -------

*** This bug has been marked as a duplicate of 15909 ***