Bug 29979

Summary: segfaults upon startup
Product: [Development] Sisyphus Reporter: Michael Shigorin <mike@altlinux.org>
Component: epiphanyAssignee: Yuri N. Sedunov <aris@altlinux.org>
Status: CLOSED FIXED QA Contact: qa-sisyphus@altlinux.org
Severity: major    
Priority: P3 CC: aen@altlinux.org, ldv@altlinux.org
Version: unstable   
Hardware: x86   
OS: Linux   
Attachments:
Description Flags
епифани на работе none

Description From 2014-04-09 10:54:03
epiphany-3.12.0-alt1.1 падает после отрисовки пользовательского интерфейса по
крайней мере в локали ru_RU.UTF-8 или en_US.UTF-8; что интересно, в kk_KZ.UTF-8
работает нормально.

Воспроизводится на
http://nightly.altlinux.org/sisyphus/snapshots/20140409/regular-gnome3-20140409-i586.iso
------- Comment #1 From 2014-04-15 12:31:30 -------
http://nightly.altlinux.org/sisyphus/snapshots/20140415/regular-cinnamon-20140415-i586.iso
-- epiphany продолжает падать, было бы здорово поправить это сегодня, чтоб
вошло в завтрашний еженедельный "релиз".
------- Comment #2 From 2014-04-15 13:04:08 -------
Created an attachment (id=6084) [details]
епифани на работе
------- Comment #3 From 2014-04-15 13:04:42 -------
умвр
------- Comment #4 From 2014-04-16 12:49:28 -------
На сегодняшней регулярке продолжает падать в ru_RU:

[  112.875940] epiphany[3501]: segfault at 19 ip b452783f sp bfcff860 error 4
in libc-2.17.so[b44df000+172000]

В en_US, uk_UA, tt_RU, kk_KZ, es_ES, pt_BR тоже упало; вот для es_ES:

[   36.149804] epiphany[3391]: segfault at 1a ip b447283f sp bfc23bb0 error 4
in libc-2.17.so[b442a000+172000]

Посмотри с livecd по возможности, я вторую неделю не анонсирую альтовскую
сборку с GNOME 3.12 именно из-за браузера.  Что у тебя работает, даже не
сомневаюсь :-)
------- Comment #5 From 2014-04-26 00:29:42 -------
На этой неделе пришлось затормозить сборку regular-gnome3.iso и поставить
ссылки на последние исошки с 3.10. :(  Понимаю, что грабли странные, но в
"чистой" среде с рекомендованным метапакетом они всё же воспроизводятся.
------- Comment #6 From 2014-05-07 23:58:04 -------
Заметил изменения в (мета)пакетах, попробовал собрать образы на опубликованном
сегодня сизифе -- в сборке под x86_64 браузер падать перестал на всех
проверенных локалях (ru/uk/es/en), а вот под i586 продолжает падать (тоже на
всех).

Собрал вполуручную 64-битную исошку, доопубликовал:
http://nightly.altlinux.org/sisyphus/snapshots/20140507/regular-gnome3-20140507-x86_64.iso

32-битная в сторонке для более удобного воспроизведения баги при желании:
http://ftp.linux.kiev.ua/pub/Linux/ALT/people/mike/iso/mkimage-profiles/tmp/regular-gnome3-20140507-i586.iso

Хорошо бы до следующей среды понять, что ж с ним такое, да собирать штатно.
------- Comment #7 From 2014-06-24 11:42:50 -------
Сегодня на
http://nightly.altlinux.org/sisyphus/snapshots/20140624/regular-gnome3-20140624-i586.iso
пронаблюдал занятное: epiphany запустился, в области отображения содержимого
была одна строчка "(null)" -- на глаз где-то десятая сверху вплотную к левому
краю, если таким же шрифтом считать.  Последующие запуски продолжили приводить
к падениям после отрисовки интерфейса.

Пока приходится убирать 32-битную сборку перед публикацией "релизов" по средам.
------- Comment #8 From 2014-06-24 11:50:29 -------
Не помню, было ли такое раньше, но сейчас при запуске из xterm следующее:

[altlinux@localhost ~]$ epiphany http://altlinux.org

** (WebKitWebProcess:3979): WARNING **: uri_tester_compile_regexp: Произошла
ошибка при компиляции регулярного выражения -Banner-Ad)- у символа с номером
10: ) без открывающей (
Ошибка сегментирования
------- Comment #9 From 2014-09-29 18:18:59 -------
На 3.14.0-alt1 не воспроизводится.