Bug 5952

Summary: apt-shell segfault
Product: [Development] Sisyphus Reporter: Ivan Zakharyaschev <imz@altlinux.org>
Component: aptAssignee: Sergey Bolshakov <sbolshakov@altlinux.org>
Status: CLOSED WORKSFORME QA Contact: qa-sisyphus@altlinux.org
Severity: minor    
Priority: P2 CC: at@altlinux.org, boyarsh@altlinux.org, imz@altlinux.org, ldv@altlinux.org, php-coder@altlinux.org
Version: unstable   
Hardware: all   
OS: Linux   

Description From 2005-01-25 21:57:30
A reproducable segfault of apt-shell. (Although I do not know the semantics of
the involved apt-shell's `script' command.)

Produced on apt-0:0.5.15cnc6-alt6, apt-0:0.5.15cnc6-alt6.1.
Steps to Reproduce:
[root@tosha root]# apt-shell
Reading Package Lists... Done
Building Dependency Tree... Done
Welcome to the APT shell. Type "help" for more information.
apt> script /bin/true
Segmentation fault
------- Comment #1 From 2005-11-26 00:45:51 -------
apt-shell'ом у нас теперь Сергей заведует.
------- Comment #2 From 2007-08-01 16:58:44 -------
У меня не падает:

apt> script /bin/true
W: Error loading script: /bin/true:1: unexpected symbol near 'char(127)'
W: Error running script: attempt to call a table value
apt>
------- Comment #3 From 2008-01-05 07:57:04 -------
Да, у меня теперь тоже не падает. apt-0.5.15lorg2-alt18