Bug 6610

Summary: libelf-0.97-alt1 из updates удаляет net-snmp-5.1.1-alt1.1
Product: [Archive] ALT Linux 2.4 Reporter: Andrei Bulava <abulava@altlinux.org>
Component: net-snmpAssignee: Kostya Timoshenko <kt@altlinux.org>
Status: CLOSED FIXED QA Contact: Andrey Cherepanov <cas@altlinux.org>
Severity: critical    
Priority: P2 CC: ldv@altlinux.org
Version: 2.4   
Hardware: all   
OS: Linux   

Description From 2005-04-21 16:58:24
Избыточная зависимость от libelf.so.* в пакете net-snmp устранена в текущем
Sisyphus, но неожиданно и неприятно выстрелила при очередном обновлении из
updates, когда там появился libelf-0.97-alt1, принесший soname change:

# apt-get install libelf
Reading Package Lists... Done
Building Dependency Tree... Done
The following packages will be upgraded
  libelf
The following packages will be REMOVED:
  net-snmp net-snmp-utils
1 upgraded, 0 newly installed, 2 removed and 2 not upgraded.
Need to get 0B/39.1kB of archives.
After unpacking 4721kB disk space will be freed.
Do you want to continue? [Y/n] n

# rpm -qR net-snmp|grep libelf\.so
libelf.so.0

# rpm -p -q --provides
/<skip/>/Master/2.4/i586/RPMS.updates/libelf-0.97-alt1.i586.rpm |grep
libelf\.so
libelf.so.1  
libelf.so.1(ELFUTILS_1.0)  
libelf.so.1(ELFUTILS_1.1)
------- Comment #1 From 2005-04-27 14:59:59 -------
Если я всё правильно понимаю, выпуск ltrace-0.3.36-alt0.M24.1.i586.rpm вместо
набора
{ltrace-0.3.36-alt1,libelf-devel-0.97-alt1,libelf-0.97-alt1,elfutils-devel-0.97-alt1,elfutils-0.97-alt1}.i586.rpm
закроет этот баг?
------- Comment #2 From 2005-08-12 21:20:50 -------
Давно исправлено, забыл изменить статус :-)