Bug 9604

Summary: Constructor missing from pkgCache::PrvIterator
Product: [Development] Sisyphus Reporter: Sir Raorn <raorn@raorn.name>
Component: aptAssignee: Gleb F-Malinovskiy <glebfm@altlinux.org>
Status: CLOSED FIXED QA Contact: qa-sisyphus@altlinux.org
Severity: enhancement    
Priority: P2 CC: at@altlinux.org, boyarsh@altlinux.org, imz@altlinux.org, ldv@altlinux.org
Version: unstable   
Hardware: all   
OS: Linux   
Bug Depends on:    
Bug Blocks: 7332, 7333    
Attachments:
Description Flags
apt-0.5.15lorg2-alt-constructor.patch none

Description From 2006-05-23 09:46:50
Add default constructor for pkgCache::PrvIterator, required for aptitude 0.4.1
------- Comment #1 From 2006-05-23 09:47:26 -------
Created an attachment (id=1502) [details]
apt-0.5.15lorg2-alt-constructor.patch
------- Comment #2 From 2006-05-27 15:42:52 -------
Словил ТАААААААКОЙ глюкан именно в этом месте...  Попробую подправить в
консерватории (в смысле aptitude), постараюсь чтобы этот патч не был нужен.
------- Comment #3 From 2006-07-15 15:30:07 -------
Патч нужен.  Словленный глюк не лечится, но обходится, о чём будет упомянуто в
README.ALT пакета aptitude.
------- Comment #4 From 2006-10-06 00:48:33 -------
Added in 0.5.15lorg2-alt5.