Bug 13645

Summary: Не настраивается из alterator'а
Product: [Distributions] Branch 4.0 Reporter: Lenar Shakirov <shakirov@cg.ru>
Component: foo2zjsAssignee: Denis Smirnov <mithraen@altlinux.org>
Status: CLOSED FIXED QA Contact: Q.A. 4.0 <qa-4.0@altlinux.org>
Severity: normal    
Priority: P2 CC: mithraen@altlinux.org
Version: 4.0   
Hardware: all   
OS: Linux   

Description From 2007-12-10 11:08:41
Модель принтера HP-LaserJet_1020 (да и вся серия foo2zjs принтеров) нельзя 
настроить из alterator-printers.

[root@shakirovpc ppd]# foomatic-ppdfile -p HP-LaserJet_1020
ERROR: foomatic-ppdfile: Printer 'HP-LaserJet_1020' and driver 'foo2zjs' are 
not compatible
ERROR: foomatic-ppdfile: Driver 'foo2zjs' not in database!

Причина: отсутствие файла /usr/share/foomatic/db/source/driver/foo2zjs.xml, 
который эксклудиться в спеке, но не пересекается с foomatic-db:

...
%def_without foomaticdb
...

%if_without foomaticdb
%exclude %_datadir/foomatic/db/source/driver/foo2oak.xml
%exclude %_datadir/foomatic/db/source/driver/foo2zjs.xml
...
------- Comment #1 From 2007-12-10 22:13:55 -------
Есть такое дело; хотя alterator-printers и считается неподдерживаемым, у меня
на
него тоже есть некоторые виды.
------- Comment #2 From 2007-12-10 22:26:29 -------
Исправлено в foo2zjs-20060523-alt0.9, также отправляется в backports/4.0.  Надо
будет не забыть попросить в бранч перекинуть...
------- Comment #3 From 2007-12-10 22:27:28 -------
*** Bug 13644 has been marked as a duplicate of this bug. ***