Bug 11464 - Insufficient Requires
: Insufficient Requires
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/apache2-mod_php5)
: unstable
: all Linux
: P2 blocker
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2007-04-12 10:57 by
Modified: 2008-03-30 01:04 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-04-12 10:57:04
# sudo service httpd2 start
Checking configuration sanity for httpd2:  [Thu Apr 12 10:32:58 2007] [crit] 
Apache is running a threaded MPM, but your PHP Module is not compiled to be 
threadsafe.  You need to recompile PHP.
Pre-configuration failed
                                                                                                  
[FAILED]
------- Comment #1 From 2007-04-15 16:12:07 -------
текущая схема сборки php не предусматривает его работу с httpd2-worker.
------- Comment #2 From 2007-07-15 23:57:27 -------
Даже с текущей схемой сборки PHP можно явно прописать нужную Requires, чтобы
администратор не терялся в догадках, с каким режимом httpd-* задумал его работу
мантейнер данного пакета.
------- Comment #3 From 2008-01-21 17:36:23 -------
Ну или в %description хотя бы.
------- Comment #4 From 2008-03-30 01:04:32 -------
(In reply to comment #2)
> Даже с текущей схемой сборки PHP можно явно прописать нужную Requires, чтобы
> администратор не терялся в догадках, с каким режимом httpd-* задумал его работу
> мантейнер данного пакета.

Fixed in apache2-mod_php5-5.2.5-alt1.