Bug 14348 - mouse_autosetup gets confused by non-physical input device drivers
: mouse_autosetup gets confused by non-physical input device drivers
Status: CLOSED DUPLICATE of bug 14351
: Branch 4.0
(All bugs in Branch 4.0/alterator-x11)
: 4.0
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2008-02-06 19:27 by
Modified: 2008-02-22 16:07 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-02-06 19:27:56
Если в ядре (по странной просьбе) включено, например, CONFIG_MAC_EMUMOUSEBTN,
то
получаем облом при наличии одной последовательной мышки.  Надо проверять
"Phys=":

[19:01:08] <Led> CONFIG_MAC_EMUMOUSEBTN: This provides generic support for
emulating the 2nd and 3rd mouse button with keypresses. If you say Y here, the
emulation is still disabled by default. The emulation is controlled by these
sysctl entries: /proc/sys/dev/mac_hid/mouse_button_emulation
/proc/sys/dev/mac_hid/mouse_button2_keycode
/proc/sys/dev/mac_hid/mouse_button3_keycode
[19:01:25] <gvy> он НЕ УМЕЕТ искать serial
[19:01:29] <gvy> он их НЕ пробает
[19:01:33] <gvy> он на них фолбэкается
[19:06:22] <gvy> собрал чрут с std-smp -- мыша ездит
[19:11:11] <Led> вот что /proc говорит:
I: Bus=0017 Vendor=0001 Product=0001 Version=0100N: Name="Macintosh mouse
button
emulation"P: Phys=S: Sysfs=/class/input/input2U: Uniq=H: Handlers=mouse0 event2
ts0B: EV=7B: KEY=70000 0 0 0 0B: REL=3
[19:11:37] <Led> Phys=
mouse_autosetup не обрабатывает :(
[19:14:14] <Led> вот эта строчка в mouse_autosetup может помочь:
P: Phys=) continue ;;
[19:15:05] <gvy> ща попробуем... :)
[19:18:58] <Led> главное, чтобы он устройства с "Phys=" игнорировал

Патч в процессе...
------- Comment #1 From 2008-02-06 19:28:15 -------
reassign
------- Comment #2 From 2008-02-06 20:05:18 -------

*** This bug has been marked as a duplicate of 14351 ***
------- Comment #3 From 2008-02-09 15:05:26 -------
fixed in 0.13.2-alt1