Bug 14641 - don't pick /etc/bashrc.d/ up please
: don't pick /etc/bashrc.d/ up please
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/zsh)
: unstable
: all Linux
: P2 normal
Assigned To:
:
: https://bugzilla.altlinux.org/show_bu...
:
:
: 13041
  Show dependency tree
 
Reported: 2008-02-25 10:56 by
Modified: 2009-11-28 00:28 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-02-25 10:56:50
Is it reasonable for zsh to execute scripts in /etc/bashrc.d/?

Right now it means that zsh conflicts with bash-completion since tab key becomes
unusable if both zsh-4.3.4-alt3 and bash-completion-20060301-alt05 are installed.
------- Comment #1 From 2008-02-28 14:03:42 -------
+1
------- Comment #2 From 2008-03-23 17:27:45 -------
*** Bug 15036 has been marked as a duplicate of this bug. ***
------- Comment #3 From 2008-03-24 23:51:39 -------
Common sh-scripts could/should be placed into /etc/profile.d/. Then zsh
could/should just read /etc/profile.d/ (/etc/profile). 

Or just /etc/profile.d/ would give not enough features?
------- Comment #4 From 2009-11-21 18:53:53 -------
/etc/bashrc.d/alias.sh, the only script not mirrored in /etc/profile.d/ (not
counting bash-completion.sh), will be lost.  Ye be warned.
------- Comment #5 From 2009-11-21 19:13:27 -------
zsh-1:4.3.10-alt3 -> sisyphus:

* Sat Nov 21 2009 Alexey I. Froloff <raorn@altlinux> 1:4.3.10-alt3

- Completion changes:
  + _girar: fixed typos, updated for new girar-utils
  + _girar_remote: updated for recent girar changes
  + _ri: rewritten for Ruby 1.9 support
- Startup files:
  + zshrc: do not process /etc/bashrc (closes: #14641)
------- Comment #6 From 2009-11-28 00:28:16 -------
спасибо!