Bug 1557 - Wrong \'Requires:\' for ver. 2001a-alt8
: Wrong \'Requires:\' for ver. 2001a-alt8
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/uw-imap-devel)
: unstable
: all Linux
: P4 blocker
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2002-11-14 10:17 by
Modified: 2003-08-25 15:18 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2002-11-14 10:17:09
Пакет -devel при установке тянет за собой uw-imap а этого не требуется в случае
установки данного пакета для сборки софта, требующего библиотеку c-client
(апример php-imap).

---

---
------- Comment #1 From 2002-11-15 23:28:28 -------
Может, имя libc-client-devel будет лучше?

(И в будущем хорошо бы выделить libc-client ещё и как .so).
------- Comment #2 From 2002-11-15 23:28:28 -------
Может, имя libc-client-devel будет лучше?

(И в будущем хорошо бы выделить libc-client ещё и как .so).
------- Comment #3 From 2003-02-05 16:12:59 -------
Вот это имя - самое оно для обозначения сущности, находящейся в uw-imap-devel.
Или libc-client-devel-static - хотя очень длинное, но соответствует packaging
policy (судя по содержимому).
------- Comment #4 From 2003-02-05 16:12:59 -------
Вот это имя - самое оно для обозначения сущности, находящейся в uw-imap-devel.
Или libc-client-devel-static - хотя очень длинное, но соответствует packaging
policy (судя по содержимому).
------- Comment #5 From 2003-02-06 18:17:11 -------
Там есть ещё .h -- им место в -devel.
------- Comment #6 From 2003-02-06 18:17:11 -------
Там есть ещё .h -- им место в -devel.
------- Comment #7 From 2003-02-06 18:18:05 -------
uw-imap-2001a-alt9: removed the dependency, substituted it by:

##############################
# Keep in sync with uw-imap main pkg version
# (no Requires: is required here)
Conflicts: %name < %version-%release
Conflicts: %name > %version-%release
# End of statements to keep in sync.
############################

No pkg renaming done yet because of the freeze before Master 2.2.
------- Comment #8 From 2003-02-06 18:18:05 -------
uw-imap-2001a-alt9: removed the dependency, substituted it by:

##############################
# Keep in sync with uw-imap main pkg version
# (no Requires: is required here)
Conflicts: %name < %version-%release
Conflicts: %name > %version-%release
# End of statements to keep in sync.
############################

No pkg renaming done yet because of the freeze before Master 2.2.