Bug 2539 - Фатальные сбои при попытке коннекта
: Фатальные сбои при попытке коннекта
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/sim)
: unstable
: all Linux
: P4 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2003-04-21 17:15 by
Modified: 2004-06-09 13:45 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2003-04-21 17:15:58
Проблема осталась, валится как sim, так и sim-qt если установлен ManualStatus
отличный от нуля или любой, кроме \"Неактивный\". В sim не удается
зарегистрировать имеющийся UIN (пробовал несколько), после удаления ~/.kde В
sim-qt - удается. Воспроизвожу на altlinux-release-Sisyphus-alt20030420 на двух
разных машинах. С разными ядрами и железом.
Найденный ворк-эраунд. Стартуем в состоянии отключено (ManualStatus=0), далее
выставляем все статусы по очереди (то-есть коннект в сеть). После появления
актуального состояния контакт-листа переключаюсь в нужный статус. Бывает
необходимо запустить раз 6-8, прежде чем войдет в сеть и не упадет.
---

---
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...[New Thread 1024
(LWP 1786)]
[New Thread 2049 (LWP 1787)]

(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
0x411e91f9 in wait4 () from /lib/i686/libc.so.6
#0  0x411e91f9 in wait4 () from /lib/i686/libc.so.6
#1  0x412659fc in sys_sigabbrev () from /lib/i686/libc.so.6
#2  0x40f6bb73 in waitpid () from /lib/i686/libpthread.so.0
#3  0x406ac0ad in KCrash::defaultCrashHandler(int) ()
   from /usr/lib/libkdecore.so.4
#4  0x40f69fec in pthread_sighandler () from /lib/i686/libpthread.so.0
#5  0x41175768 in sigaction () from /lib/i686/libc.so.6
#6  0x40d3cab3 in QSocket::qt_invoke(int, QUObject*) ()
   from /usr/lib/libqt-mt.so.3
#7  0x40a2f7e9 in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /usr/lib/libqt-mt.so.3
#8  0x40a2f8c5 in QObject::activate_signal(int, int) ()
   from /usr/lib/libqt-mt.so.3
#9  0x40d0fee2 in QSocketNotifier::activated(int) ()
   from /usr/lib/libqt-mt.so.3
#10 0x40a4bd60 in QSocketNotifier::event(QEvent*) ()
   from /usr/lib/libqt-mt.so.3
#11 0x409d1544 in QApplication::internalNotify(QObject*, QEvent*) ()
   from /usr/lib/libqt-mt.so.3
#12 0x409d0d0b in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/libqt-mt.so.3
#13 0x4063f169 in KApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/libkdecore.so.4
#14 0x409ac51a in QEventLoop::activateSocketNotifiers() ()
   from /usr/lib/libqt-mt.so.3
#15 0x40989c27 in QEventLoop::processEvents(unsigned) ()
   from /usr/lib/libqt-mt.so.3
#16 0x409e53c6 in QEventLoop::enterLoop() () from /usr/lib/libqt-mt.so.3
#17 0x409e5268 in QEventLoop::exec() () from /usr/lib/libqt-mt.so.3
#18 0x409d1771 in QApplication::exec() () from /usr/lib/libqt-mt.so.3
#19 0x080b30b4 in simMessageOutput(QtMsgType, char const*) ()
#20 0x41164642 in __libc_start_main () from /lib/i686/libc.so.6
------- Comment #1 From 2003-04-24 20:55:47 -------
Похоже наконец пофиксили. Спасибо! :-))
------- Comment #2 From 2003-04-24 20:55:47 -------
Похоже наконец пофиксили. Спасибо! :-))
------- Comment #3 From 2003-04-25 10:46:12 -------
ПОфиксено в alt0.6
------- Comment #4 From 2003-04-25 10:46:12 -------
ПОфиксено в alt0.6