Bug 3925 - stmpclean removes listening unix domain sockets
: stmpclean removes listening unix domain sockets
Status: CLOSED NOTABUG
: Sisyphus
(All bugs in Sisyphus/stmpclean)
: unstable
: all Linux
: P2 blocker
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2004-04-05 16:50 by
Modified: 2005-07-13 15:45 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2004-04-05 16:50:45
stmpclean removes /tmp/.X11-unix/XNUMBER sockets (from Xvnc at least). also it
does not remove temporary directores created in /tmp by kdm.
------- Comment #1 From 2004-04-06 13:32:10 -------
Why should it keep these sockets? 
Why should it remove these directories? 
 
------- Comment #2 From 2004-04-06 13:37:22 -------
It should not remove that socket because Xvnc still running and accepts
connections on it.
It should remove that directories because kdm creates new random dir every time
he starts and dont use previous dirs.
------- Comment #3 From 2004-04-14 16:34:42 -------
1. stmpclean removes old sockets only.  Unless /tmp is mounted with "noatime"
option, access 
time of the socket is updated each time new client is connected. 

2. According to stmpclean(8), 
"The stmpclean utility never removes files or directories owned by root. 
It is a feature, not a bug." 

I think that kdm should create its tmp directories in more appropriate place,
so they could be 
removed by /etc/rc.d/scripts/cleanup. 
------- Comment #4 From 2004-04-14 17:27:07 -------
> I think that kdm should create its tmp directories 
> in more appropriate place, so they could be  
>  removed by /etc/rc.d/scripts/cleanup. 
Ok. 
/tmp/kde-kdm-XXXXXX 
------- Comment #5 From 2004-06-10 15:27:24 -------
$ mkdir /tmp/a
$ mksock /tmp/a/uuu
$ touch /tmp/a/ggg
$ sleep 10
$ stmpclean -v -t 0s
stmpclean[7823]: removed file /tmp/a/ggg
$ ls -la /tmp/a
итого 8
drwxr-xr-x  2 voins voins 4096 Июн 10 15:21 .
drwxrwxrwt  7 root  root  4096 Июн 10 15:20 ..
srwxr-xr-x  1 voins voins    0 Июн 10 15:20 uuu

отсюда вывод: stmpclean не удаляет сокеты, что подтверждается чтением
исходников.