Bug 7409 - find-requires for %pre/%preun/%post/%postun scriplets
: find-requires for %pre/%preun/%post/%postun scriplets
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/rpm-build)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
: 2603
  Show dependency tree
 
Reported: 2005-07-20 18:42 by
Modified: 2008-02-26 00:20 (History)


Attachments
patch for build/files.c (5.59 KB, text/plain)
2005-07-20 18:44, at@altlinux.org
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-07-20 18:42:35
Here is my attempt to implement dependency tracking for rpm %pre/%post scripts.
The idea is that we can save script contents under %buildroot and process it
just as usual file.  We then tap into generateDepends() to do the rest of the
work.
------- Comment #1 From 2005-07-20 18:44:20 -------
Created an attachment (id=1009) [details]
patch for build/files.c

The patch is not tested thoroughly, but known to work in a few simple cases.
------- Comment #2 From 2005-09-05 00:23:23 -------
Interesting.  Do we need this dependency tracker to be enabled by default?
Right now we have no way to control such tracker.
------- Comment #3 From 2005-09-05 00:40:56 -------
*** Bug 4397 has been marked as a duplicate of this bug. ***
------- Comment #4 From 2008-01-24 22:26:00 -------
Я в этом патче делал так что просто временный файл со скриптом подаётся на вход
find-requires (вместе с остальными файлами из payload).  Так что это может
управляться через те же ручки, что и зависимости в файлах подпакета (AutoReq,
AutoProv).  Это наверное неправильно.
------- Comment #5 From 2008-01-24 23:35:09 -------
Ой, кажется я неправильно написал что скрипт вместе с payload обрабатывался.
------- Comment #6 From 2008-02-25 23:14:07 -------
implemented in 4.0.4-alt87