Bug 12667

Summary: openal.pc contains unexpanded macro
Product: [Development] Sisyphus Reporter: Michael Shigorin <mike@altlinux.org>
Component: libopenal-develAssignee: Valery Inozemtsev <shrek@altlinux.org>
Status: CLOSED FIXED QA Contact: qa-sisyphus@altlinux.org
Severity: major    
Priority: P2 CC: icesik@altlinux.org
Version: unstable   
Hardware: all   
OS: Linux   

Description From 2007-09-02 00:00:07
Сборка из 4.0/branch, но она же наблюдается и в Sisyphus (0.0.8-alt3) --
побился
pkgconfig-файл (интересно, а для них есть валидатор?):

$ pkg-config --libs openal   
Package @requirements@ was not found in the pkg-config search path.
Perhaps you should add the directory containing `@requirements@.pc'
to the PKG_CONFIG_PATH environment variable
Package '@requirements@', required by 'OpenAL', not found
$ cat /usr/lib/pkgconfig/openal.pc
prefix=/usr
exec_prefix=/usr
libdir=/usr/lib
includedir=/usr/include

Name: OpenAL
Description:  OpenAL is a cross-platform 3D audio API.
Requires: @requirements@
Version: 0.0.8
Libs: -lopenal
Cflags:
------- Comment #1 From 2007-10-12 20:33:18 -------
как я погляжу, это проблема в релизе 0.0.8 апстрима, и только сейчас всплыла.
будет ли корректно просто удалить это поле?
------- Comment #2 From 2007-10-12 21:27:10 -------
libopenal-0.0.8-alt4 ушел в сизиф