Bug 15269
| Summary: | Ошибка проверки версии в /etc/init.d/postgresql | ||
|---|---|---|---|
| Product: | Sisyphus | Reporter: | Sergey N. Yatskevich <syatskevich> |
| Component: | postgresql8.3-server | Assignee: | Michael Bochkaryov <misha> |
| Status: | CLOSED FIXED | QA Contact: | qa-sisyphus |
| Severity: | normal | ||
| Priority: | P2 | CC: | misha, mithraen, ns, thresh, vvk |
| Version: | unstable | ||
| Hardware: | all | ||
| OS: | Linux | ||
Действительно, в проверке ошибка есть. Сегодня постараюсь залить исправленный вариант. Пакет исправлен и уехал в Сизиф с версией 8.3.1-alt3. |

Description
Sergey N. Yatskevich 2008-04-08 15:24:57 MSDОшибка проверки версии в скрипте запуска сервера postgresql из-за чего сервер не запускается. Есть: if [ `cat "$PG_CHROOT_DIR$PGDATA/PG_VERSION"` != '8.2' ];<->then msg_starting postgresql failure "Old version. Need to Upgrade. See /usr/share/doc/postgresql-8.2/ echo return 1 fi Должно быть: if [ `cat "$PG_CHROOT_DIR$PGDATA/PG_VERSION"` != '8.3' ];<->then msg_starting postgresql failure "Old version. Need to Upgrade. See /usr/share/doc/postgresql-8.3/ echo return 1 fi