Bug 17431

Summary: gutenprint from gimp doesn't work for okipage 8w Lite
Product: [Distributions] Branch 4.0 Reporter: Ivan Zakharyaschev <imz@altlinux.org>
Component: gimp-plugin-gutenprintAssignee: Valery Inozemtsev <shrek@altlinux.org>
Status: CLOSED WONTFIX QA Contact: Q.A. 4.0 <qa-4.0@altlinux.org>
Severity: normal    
Priority: P2    
Version: 4.0   
Hardware: all   
OS: Linux   

Description From 2008-10-04 03:37:30
4.0.3 --
ftp://ftp.altlinux.ru/pub/distributions/ALTLinux/4.0/Desktop/4.0.3/iso/altlinux-4.0.3-lite-i586-install_ru-cd.iso

How to reproduce: I opened an image in gimp:

$ gimp /usr/share/themes/ALTLinux-Lite/splash.png

, selected in menu "File" > "Print with Gutenprint", then tried to setup it for
the printer. The real printer is "okipage 8w Lite". Such a printer wasn't
present in the list of guteprint, so I selected "okipage 8p". Then I proceeded
to print the image. The new job appeared in the print queue (lpq), but the
printer did nothing. A few minutes passed, and the job disappeared from the
queue.

Workaround: print the image from gqview. (Simple "lp" is not that convenient
because it's more difficult to select the zoom and position in command line.)
------- Comment #1 From 2008-10-04 04:38:51 -------
I recalled that when configuring CUPS, I was able to select the correct model
of the printer. So, it's not a model completely unknown to the world of
GNU/Linux. /etc/cups/ppd/oki.ppd reads:

*FormatVersion:    "4.3"
*FileVersion:    "1.1"
*LanguageVersion: English 
*LanguageEncoding: ISOLatin1
*PCFileName:    "OKI4W.PPD"
*Manufacturer:    "Okidata"
*Product:    "(Okipage 8w Lite)"
*cupsVersion:    1.0
*cupsManualCopies: True
*cupsModelNumber:  2
*cupsFilter:    "application/vnd.cups-postscript 0 foomatic-rip"
*%pprRIP:        foomatic-rip other
*ModelName:     "Okidata Okipage 8w Lite"
*ShortNickName: "Okidata Okipage 8w Lite oki4w"
*NickName:      "Okidata Okipage 8w Lite Foomatic/oki4w (recommended)"

etc.

So, gutenprint could also suggest an exact option for this printer.

But this comment is not essential: I doubt that the problem comes from an
incorrect model specification in gutenprint's menu. I believe that simply
gutenprint doesn't work well.
------- Comment #2 From 2008-11-25 20:09:38 -------
(In reply to comment #0)

> Workaround: print the image from gqview. (Simple "lp" is not that convenient because it's more difficult to select the zoom and position in
> command line.)

But still (gqview or whatever else), printing through the driver which is
included in the distro is very bad:
https://bugzilla.altlinux.org/show_bug.cgi?id=17558 .
------- Comment #3 From 2008-11-25 20:14:15 -------
$ rpm -qa '*guten*'
libgutenprint-5.0.2-alt1.M40.1
gutenprint-foomatic-5.0.2-alt1.M40.1
gutenprint-5.0.2-alt1.M40.1
gimp-plugin-gutenprint-5.0.2-alt1.M40.1
$ 
------- Comment #4 From 2008-11-25 20:23:10 -------
my your not understand
------- Comment #5 From 2009-01-03 20:09:29 -------
для 4.0 только обновление безопасность