Bug 27282

Summary: ошибка определения версии cups в /usr/bin/loadconfig
Product: [Development] Sisyphus Reporter: Andrey Chichak <Andrey.Chichak@gmail.com>
Component: freenx-serverAssignee: Michael Shigorin <mike@altlinux.org>
Status: CLOSED FIXED QA Contact: qa-sisyphus@altlinux.org
Severity: normal    
Priority: P3    
Version: unstable   
Hardware: all   
OS: Linux   

Description From 2012-05-01 10:15:13
версия cups 1.5.2, как результат bc не может это сравнить с 1.2 и получаем
ошибку:

/usr/bin/nxloadconfig: line 696: [: -ne: unary operator expected

как вариант обхода - прописываем неправильный COMMAND_CUPSD, ошибка пропадает
вместе с возможностью печатать.
------- Comment #1 From 2012-05-01 10:22:39 -------
версии пакетов:

[root@i node.conf.d]# rpm -qa | grep nx
nx-3.5.0-alt1
freenx-server-0.7.4-alt30
------- Comment #2 From 2012-05-06 00:53:17 -------
-egrep 'CUPS\/1\.' | head -1 | sed 's|CUPS\/||'` >= 1.2" | bc
+egrep 'CUPS\/1\.' | head -1 | sed 's|CUPS\/\(1\.[0-9]\+\).*|\1|'` >= 1.2" | bc
------- Comment #3 From 2012-05-06 02:18:14 -------
freenx-server-0.7.4-alt31 -> sisyphus:

* Sat May 05 2012 Michael Shigorin <mike@altlinux> 0.7.4-alt31
- fix broken CUPS version test in nxloadconfig (closes: #27282)
- fix broken NX version test there either (closes: #27283)