Bug 33085

Summary: падает adobe flash player
Product: [Development] Sisyphus Reporter: Anton Farygin <rider@altlinux.org>
Component: firefoxAssignee: Alexey Gladkov <legion@altlinux.org>
Status: CLOSED FIXED QA Contact: qa-sisyphus@altlinux.org
Severity: major    
Priority: P3 CC: cas@altlinux.org, imz@altlinux.org, lav@altlinux.org, mike@altlinux.org, rider@altlinux.org, ruslandh@altlinux.org, sbolshakov@altlinux.org, stalker@altlinux.org, zerg@altlinux.org
Version: unstable   
Hardware: all   
OS: Linux   
Bug Depends on: 32297    
Bug Blocks: 31995, 32883    

Description From 2017-02-07 15:18:36
Любая версия adobe flash player на нашей сборке firefox падает, на апстримной
при этом работает нормально.

firefox-51.0.1-alt1.x86_64
mozilla-plugin-adobe-flash-24.0.0.186-alt0.M70P.1.x86_64
------- Comment #1 From 2017-02-07 15:31:59 -------
(В ответ на комментарий №0)
> на апстримной при этом работает нормально.
На firefox-esr-45.7.0-alt1 тоже работает.
------- Comment #2 From 2017-02-08 00:26:52 -------
У меня на апстримной он тоже падает, но раз у вас работает...
У меня по логам видно, что оно опять выбирает не тот gtk.
------- Comment #3 From 2017-02-08 07:59:10 -------
Апстримная лезет не в тот каталог за плагином, ей нужно симплинк сделать:
/usr/lib/mozilla/plugins -> /usr/lib64/browser-plugins

После этого работает, проверили на двух машинах.
------- Comment #4 From 2017-02-08 16:14:43 -------
Причина в добавлении RPATH
(https://bugzilla.altlinux.org/show_bug.cgi?id=32297).
------- Comment #5 From 2017-02-08 16:16:34 -------
Я добавлю выставление LD_LIBRARY_PATH вместо RPATH.
------- Comment #6 From 2017-02-08 22:17:10 -------
(In reply to comment #5)
> Я добавлю выставление LD_LIBRARY_PATH вместо RPATH.

Пока не очень понятен механизм того, как не та gtk выбиралась. Посмотрю разницу
в поведении старой сборки и с LD_LIBRARY_PATH, чтобы разобраться.
------- Comment #7 From 2017-02-09 12:50:01 -------
firefox-51.0.1-alt2 -> sisyphus:

* Wed Feb 08 2017 Alexey Gladkov <legion@altlinux> 51.0.1-alt2
- Remove RPATH but began to use LD_LIBRARY_PATH (ALT#33085).
------- Comment #8 From 2017-02-09 14:14:58 -------
2 Cas: В p8 наверняка очень актуально.
------- Comment #9 From 2017-02-10 12:21:33 -------
(В ответ на комментарий №8)
> 2 Cas: В p8 наверняка очень актуально.
Неактуально. Потому как там всё работает.
------- Comment #10 From 2017-02-10 20:58:06 -------
(В ответ на комментарий №9)
> там всё работает.
С чего бы?
------- Comment #11 From 2017-02-14 12:08:17 -------
(В ответ на комментарий №10)
> (В ответ на комментарий №9)
> > там всё работает.
> С чего бы?
С того, что работает. ppapi-plugin-adobe-flash+firefox-pepperflash
------- Comment #12 From 2017-02-15 14:29:18 -------
(В ответ на комментарий №11)
> > > там всё работает.
> > С чего бы?
> С того, что работает.
С чего бы неработающее у кого-то волшебным образом заработало?

> ppapi-plugin-adobe-flash+firefox-pepperflash
Без разницы.
------- Comment #13 From 2017-02-17 09:41:25 -------
Если всё работает в p8, тогда почему не закрыта
https://bugzilla.altlinux.org/show_bug.cgi?id=31995
------- Comment #14 From 2017-02-17 12:26:16 -------
Потому что не работает в p8.
------- Comment #15 From 2017-02-17 13:05:17 -------
31995 и висит на p8.
------- Comment #16 From 2017-03-12 11:44:18 -------
*** Bug 32883 has been marked as a duplicate of this bug. ***