Bug 46254
| Summary: | vnstat демон не работает,не имеет доступа к директории | ||||||
|---|---|---|---|---|---|---|---|
| Product: | Branch p10 | Reporter: | Константин <kostyaem9> | ||||
| Component: | vnstat | Assignee: | qa-team <qa-team> | ||||
| Status: | CLOSED NOTABUG | QA Contact: | qa-p10 <qa-p10> | ||||
| Severity: | critical | ||||||
| Priority: | P5 | CC: | amakeenk | ||||
| Version: | не указана | ||||||
| Hardware: | x86_64 | ||||||
| OS: | Linux | ||||||
| Attachments: |
|
||||||
Установите пакет vnstat-server и запустите сервис:
# systemctl start vnstatd
После этого данной ошибки не будет:
# vnstat
ens19: Not enough data available yet.
> На команду "sudo sustemctl start vnstat" ругается: Failed to start
> vnstat.service: Unit vnstat.service not found.
Правильно ругается, потому что он называется не так.
|

Description
Константин 2023-05-24 22:32:02 MSKCreated attachment 13261 [details] Терминал с командами по запуску vnstat Из официального репозитория p10 установил vnStat 2.7 by Teemu Toivola. Командой "sudo vnstat" программа не запускается, пишет: Error: Failed to open database "/var/lib/vnstat/vnstat.db" in read-only mode. The vnStat daemon should have created the database when started. Check that it is configured and running. See also "man vnstatd". You have new mail. При добавлении интерфейса пишет: смотри ответ выше. На команду "sudo sustemctl enable vnstat" ругается: Failed to enable unit: Unit file vnstat.service does not exist. На команду "sudo sustemctl start vnstat" ругается: Failed to start vnstat.service: Unit vnstat.service not found. ОС: Альт Рабочая станция К 10.1, ядро: 6.1.29-un-def-alt1