Bug 10039 - upgrade from previous version fails
: upgrade from previous version fails
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/emacs-mode-auctex)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2006-09-25 19:51 by
Modified: 2006-09-27 15:40 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-09-25 19:51:23
upgrade preview-mode-latex
from previous version fails
We need Obsoletes: emacs-preview-latex < 11.83

Сделал бакпорт и пофиксил спек.
1) не сносило 
emacs-preview-latex = 11.81

2) там можно почистить BuildRequires:
все равно el-pkgutilы
не используются и вообще лежат сейчас в другом месте.
пат прилагаю.
 
--- auctex.spec	2006-08-24 18:40:43 +0300
+++ auctex.spec	2006-09-23 23:51:46 +0300
@@ -33,6 +33,7 @@
 # any site-specific variables for AUC TeX.
 
 Provides: emacs-preview-latex = %version-%release
+Obsoletes: emacs-preview-latex < 11.82
 
 Obsoletes: auctex
 
@@ -56,8 +57,8 @@
 %(echo 'emacs provides the used Emacs Lisp compiler (%emacsbin)' 1>&2)
 %endif
 
-# We need el-pkgutils to genreate file-lists:
-BuildPreReq: emacs-common >= 21.1-alt11
+# We DONT need el-pkgutils to genreate file-lists:
+#BuildPreReq: emacs-common >= 21.1-alt11
 
 %description
 AUC TeX is a comprehensive, customizable, integrated environment for
------- Comment #1 From 2006-09-26 22:14:08 -------
Fixed in 11.83-alt2
------- Comment #2 From 2006-09-27 15:40:46 -------
thanks.