Bug 10293 - hasher passes build requirements to underlying apt incorrectly in some cases
: hasher passes build requirements to underlying apt incorrectly in some cases
Status: CLOSED NOTABUG
: Sisyphus
(All bugs in Sisyphus/hasher)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2006-11-20 08:45 by
Modified: 2006-11-20 08:56 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-11-20 08:45:41
If we have specifically formed virtual requirements in the BuildRequires list, 
e.g. perl(Module/Build.pm), it's impossible to build the package via hasher.
Output log shows that hasher incorrectly passes build requirements to the 
underlying apt system:
------------------------------
rebuild: perl-Mail-Sender-0.8.10-alt1.src.rpm: fetched build dependencies.
rebuild: perl-Mail-Sender-0.8.10-alt1.src.rpm: calculated build dependencies: 
perl-devel perl(Module/Build.pm)
install: changed working directory to `/mnt/old/home/alex/RPM/hsh'
Reading Package Lists...
Building Dependency Tree...
E: Couldn't find package perl(Module
install: failed to calculate package file list.
install: Failed to generate package file list.
--------------------------------

hasher version: 1.0.34-alt1
I should mention that [some] previous versions of hasher didn't had this bug 
(otherwise I couldn't upload the package mentioned to Sisyphus :-))
Steps to Reproduce:
One can try to rebuild the mentioned package via hasher.
------- Comment #1 From 2006-11-20 08:56:25 -------
Please take my excuses.

The problem I described is caused by a local repository misconfiguration.