Bug 10312 - Пересобрать с новой libmysqlclient
: Пересобрать с новой libmysqlclient
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/mod_auth_mysql)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2006-11-23 20:52 by
Modified: 2006-12-15 11:58 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-11-23 20:52:28
При использовании текущей mod_auth_mysql с mysql>4.0 (4.1,5.x) штатно он не
работает. Выдается ошибка:
Client does not support authentication protocol requested
by server; consider upgrading MySQL client
На http://dev.mysql.com/doc/refman/5.0/en/old-client.html написано:
To solve this problem, you should use one of the following approaches:
* Upgrade all client programs to use a 4.1.1 or newer client library.
* When connecting to the server with a pre-4.1 client program, use an account
that still has a pre-4.1-style password. 

То есть, пароли всем пользователям нужно задавать через функцию OLD_PASSWORD().
Логичнее пересобрать пакет с libmysqlclient от mysql5?  Или от этого развалится
что-то еще?
------- Comment #1 From 2006-12-15 11:58:07 -------
reassign
------- Comment #2 From 2006-12-15 11:58:38 -------
Fixed in 3.0.0-alt1