Bug 10434 - mount-2.12r-alt3 does not pass the "quiet" option to vfat properly
: mount-2.12r-alt3 does not pass the "quiet" option to vfat properly
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/mount)
: unstable
: all Linux
: P3 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2006-12-15 21:35 by
Modified: 2007-02-23 20:15 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-12-15 21:35:30
Between mount-2.12r-alt1 and mount-2.12r-alt3 handling of the "quiet" mount
option for vfat filesystem has been broken (/etc/mtab shows the "quiet" option,
but actually it is not enabled).

Steps to Reproduce:
With mount-2.12r-alt1:
# strace -q -e mount -s 1024 mount -t vfat -o quiet /dev/sdb1 /mnt/disk
mount("/dev/sdb1", "/mnt/disk", "vfat", MS_MGC_VAL, "quiet") = 0

With mount-2.12r-alt3:
# strace -q -e mount -s 1024 mount -t vfat -o quiet /dev/sdb1 /mnt/disk
mount("/dev/sdb1", "/mnt/disk", "vfat", MS_MGC_VAL|MS_VERBOSE, "") = 0
------- Comment #1 From 2006-12-15 22:26:27 -------
Between alt1 and alt2 (very likely) or between alt2 and alt3?
------- Comment #2 From 2006-12-15 22:33:45 -------
Seems that the problem is caused by the addition of MS_SILENT to kernel headers:

http://lkml.org/lkml/2006/3/14/112

Rebuilding mount-2.12r-alt1 package fails for me due to broken chstk on x86_64,
but the mount binary which gets built is broken in the same way (eats the
"quiet" option).
------- Comment #3 From 2006-12-15 22:43:54 -------
Yes, regression is due to rebuild.
------- Comment #4 From 2006-12-16 00:03:10 -------
Looks like MS_SILENT handling in mount is wrong:

#ifdef MS_SILENT
if (om->mask == MS_SILENT && om->inv)  {
        mount_quiet = 1;
        verbose = 0;
}

i.e. MS_SILENT meaning is reverted.
------- Comment #5 From 2006-12-16 00:22:45 -------
Cited hunk (while buggy) is not relevant to the problem.

I wonder how mount should work when "quiet" option is given.
Should it set MS_SILENT (== MS_VERBOSE) flag in mount(2) call?
Should it pass "quiet" option to mount(2) call?
------- Comment #6 From 2007-01-29 02:18:45 -------
Возможно ли решить данную неприятную проблему в ближайшие сроки?
------- Comment #7 From 2007-01-29 05:14:00 -------
+1 к предыдущему комментатору.
------- Comment #8 From 2007-01-29 17:45:07 -------
Я бы хотел услышать предложения возможных решений.
------- Comment #9 From 2007-02-02 03:31:34 -------
Disabled MS_SILENT support in 2.12r-alt5.