Bug 10701 - expect hangs in SIGSEGV loop
: expect hangs in SIGSEGV loop
Status: CLOSED WORKSFORME
: Sisyphus
(All bugs in Sisyphus/expect)
: unstable
: all Linux
: P2 critical
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2007-01-23 02:18 by
Modified: 2008-02-15 23:20 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-01-23 02:18:42
current expect no longer works in current build env for binutils testsuite:
$ hsh --mount=/dev/pts binutils-2.17.50.0.3-alt1.src.rpm
hangs in expect:
# strace -p `pidof expect`
Process 12345 attached - interrupt to quit
--- SIGSTOP (Stopped (signal)) @ 0 (0) ---
--- SIGSTOP (Stopped (signal)) @ 0 (0) ---
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
rt_sigreturn(0x6026b0)                  = 0
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
rt_sigreturn(0x6026b0)                  = 0
...
Same happens with testcase from binutils-2.17.50.0.6-alt1.src.rpm

Regression is due to glibc update:
In glibc-2.3.6-alt7 based environment (e.g. Sisyphus/2006/10/02) expect works,
in glibc-2.5 based environment (e.g. Sisyphus/2006/10/03) expect hangs.
------- Comment #1 From 2007-01-25 16:58:08 -------
пересборка binutils-2.17.50.0.6-alt1 c использованием expect-5.43-alt2
вполне себе удалась (не hasher, i586). На каком именно тесте оно hangs ?
------- Comment #2 From 2007-01-25 20:42:37 -------
                === binutils tests ===

Schedule of variations:
    unix

Running target unix
Using /usr/share/dejagnu/baseboards/unix.exp as board description file for
target.
Using /usr/share/dejagnu/config/unix.exp as generic interface file for target.
Using
/usr/src/RPM/BUILD/binutils-2.17.50.0.6/binutils/testsuite/config/default.exp as
tool-and-target-specifi
c interface file.
Running
/usr/src/RPM/BUILD/binutils-2.17.50.0.6/binutils/testsuite/binutils-all/ar.exp
...

hasher-priv: master: idle time limit (3600 seconds) exceeded
------- Comment #3 From 2007-02-07 19:36:33 -------
workaround included in 5.43-alt3
------- Comment #4 From 2008-02-15 23:20:15 -------
re
------- Comment #5 From 2008-02-15 23:20:58 -------
so sorta fixed?