Bug 10766 - Missing requires?
: Missing requires?
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/libImageMagick-devel)
: unstable
: all Linux
: P2 blocker
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2007-02-04 16:34 by
Modified: 2007-04-06 15:34 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-02-04 16:34:53
thresh@cryo ~ $ hsh --initroot-only /hasher/sisyphus
Components: hasher
Processing pkglists... hasher done
Processing srclists...  hasher done
Creating component releases... done
Updating global release file... done
Appending MD5Sum... hasher done
All your base are belong to us!!!

thresh@cryo ~ $ hsh-install /hasher/sisyphus libImageMagick-devel
Preparing packages for installation...
libXau-1.0.3-alt1
libXdmcp-1.0.2-alt1
libX11-1.1.1-alt1
libXext-1.0.3-alt1
libexpat-2.0.0-alt3.1
libfreetype-2.3.1-alt1
fontconfig-2.3.2-alt8
Updating fonts cache: [ DONE ]
liblcms-1.15-alt1
libstdc++4.1-4.1.1-alt11
libjpeg-6b-alt7
libtiff-3.7.4-alt1
libImageMagick-6.3.2-alt1
libImageMagick-devel-6.3.2-alt1

thresh@cryo /git/packages/ruby-rmagick $ hsh-shell /hasher/sisyphus
[builder@cryo tmp]$ /usr/bin/Magick-config --libs
-lMagick -llcms -ltiff -lfreetype -ljpeg -lfontconfig -lXext -lSM -lICE -lX11
-lXt -lbz2 -lz -lpthread -lm -lpthread -lWand -lMagick

[builder@cryo tmp]$ rpm -q liblcms-devel libtiff-devel libfreetype-devel
libjpeg-devel libfontconfig-devel libXext-devel libSM-devel libICE-devel
libX11-devel libXt-devel bzlib-devel zlib-devel
warning: package liblcms-devel is not installed
warning: package libtiff-devel is not installed
warning: package libfreetype-devel is not installed
warning: package libjpeg-devel is not installed
warning: package libfontconfig-devel is not installed
warning: package libXext-devel is not installed
warning: package libSM-devel is not installed
warning: package libICE-devel is not installed
warning: package libX11-devel is not installed
warning: package libXt-devel is not installed
warning: package bzlib-devel is not installed
warning: package zlib-devel is not installed

Actual Results:  
Dependent libraries are not installed.

Expected Results:  
Package should require all the libraries needed to build a program linked with
ImageMagick.
------- Comment #1 From 2007-02-04 23:34:57 -------
Так вот что ломало ruby-rmagick!

Спасибо, Кость.
------- Comment #2 From 2007-02-04 23:41:15 -------
Нет, ломало ее скорее всего не то.

Вообще говоря мне не нравится этот беспорядок -- получается, что в каждом
клиенте libImageMagick нужно указывать тонну BuildRequires, которые в этом
клиенте не нужны.
------- Comment #3 From 2007-02-05 10:50:24 -------
все что выдает /usr/bin/Magick-config --libs нужно добавив в Requires в 
libImageMagick-devel
------- Comment #4 From 2007-02-05 16:42:39 -------
Исправлено в 6.3.2-alt2