Bug 10851 - [FR] fix behaviour in 8-bit locales with cyrillic filenames
: [FR] fix behaviour in 8-bit locales with cyrillic filenames
Status: CLOSED WONTFIX
: Sisyphus
(All bugs in Sisyphus/file-roller)
: unstable
: all Linux
: P2 enhancement
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2007-02-16 17:01 by
Modified: 2011-03-24 15:26 (History)


Attachments
initial fix (Location only but tested) (2.54 KB, patch)
2007-02-16 17:07, Michael Shigorin
no flags Details | Diff
previous patch plus one more kludgy chunk (3.48 KB, patch)
2007-02-16 19:06, Michael Shigorin
no flags Details | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-02-16 17:01:05
It was long observed that file-roller would work OK with both cyrillic archive
filenames and their content names, but mess up Location: bar in non-UTF8 locales
like ru_RU.KOI8-R and refuse to accept non-UTF8 names as command line arguments.

The patch for the former part of a problem is attached (verified); I'm trying to
fix the latter too but for now seems like I can break more than fix.

2 lav: thanks for
http://www.freesource.info/wiki/Lokalizacija/LokalizacijaProgramm#h323-5

2 eostapets: thunar-archive-plugin would try to pass filename argument to
file-roller (nice "plugin", heh) and fail if it's not UTF.  So you might be
interested too ;)
------- Comment #1 From 2007-02-16 17:07:52 -------
Created an attachment (id=1805) [details]
initial fix (Location only but tested)

UTF8 test passed for me too
------- Comment #2 From 2007-02-16 19:01:57 -------
I've kludged around opening archives from commandline but it's sort of band-aid
-- window title, recent files and archive creation are broken (in non-utf setup).
------- Comment #3 From 2007-02-16 19:04:47 -------
Passing on to an actual (so far) maintainer.
------- Comment #4 From 2007-02-16 19:06:42 -------
Created an attachment (id=1806) [details]
previous patch plus one more kludgy chunk

This sort of fixes opening cyrillic named archives from commandline but should
definitely break something and is incomplete anyways: window title, recent
files and archive _creation_ aren't cared for at all.

Actually it might make sense to have window->locale_filename, no?
------- Comment #5 From 2008-04-13 13:29:03 -------
WONTFIX?
------- Comment #6 From 2010-01-06 20:56:08 -------
*** Bug 22462 has been marked as a duplicate of this bug. ***
------- Comment #7 From 2011-03-24 15:26:05 -------
APPARENTLY.