Bug 1149 - XFree86 4.2.0-alt7 would lockup when trying to use Xv on Savage4 chips
: XFree86 4.2.0-alt7 would lockup when trying to use Xv on Savage4 chips
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/XFree86-server)
: unstable
: all Linux
: P4 critical
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2002-08-01 15:36 by
Modified: 2005-08-30 02:14 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2002-08-01 15:36:40
PoC: just run xine out of ALM2 or J2 box on KM133 system (integrated
Savage4)...

Workaround: add \'Option  \"omit XVideo\"\' to \'SubSection
\"extmod\"\' in XF86Config-4
---

---
see Jul 31--Aug 01, 2002 discussion in devel@
------- Comment #1 From 2002-11-25 17:51:19 -------
Fixed in 4.2.1-alt4
------- Comment #2 From 2002-11-25 17:51:19 -------
Fixed in 4.2.1-alt4
------- Comment #3 From 2003-02-01 03:20:13 -------
if it was only worked around \"my way\"
------- Comment #4 From 2003-02-01 03:20:13 -------
if it was only worked around \"my way\"
------- Comment #5 From 2003-02-01 03:25:52 -------
Возможно, есть более правильный вариант.

<a href="http://altlinux.ru/pipermail/community/2003-January/070969.html">http://altlinux.ru/pipermail/community/2003-January/070969.html</a> :

I am pleased to announce that a new drop of the Savage driver, version
1.1.25t, is now available on my web site at
<a href="http://www.probo.com/timr/savage40.html">http://www.probo.com/timr/savage40.html</a>.

This drop contains fixes for the two most commonly reported problems with the
Savage driver: the hangs in the \&quot;blaster\&quot; and \&quot;critical\&quot; modules of
xscreensaver, and the hang in \&quot;xine\&quot;.  All of these are now gone.

In addition, this drop contains support for the \&quot;xgamma\&quot; XFree86 extension.
This allows you to use the \&quot;xgamma\&quot; tool at depth 24 to adjust the gamma ramp
of the chips DAC.

This drop also contains fixes for two long-standing but minor bugs, including
bad cursor colors at depth 8 on the ProSavages, and bad handling of tiled
color patterns.

I also updated s3switch to add the patch I\'ve handed out to many of you
separately, so that it assumes all devices are connected, instead of trying
to detect them.

The Linux/x86 binary was built on and for XFree86 4.2.0.  It will run
successfully in 4.1.0, if you supply the -ignoreABI switch to override the
version detection.

Both binary and source for both the driver and s3switch are on the web page.
I will be submitting a patch to XFree86 by the end of the week.

Thanks to all of you who submitted patches, bug reports, and general warm
thoughts.

--
- Tim Roberts, <a href="mailto:timr@probo.com" target="_new">timr@probo.com</a>
  Providenza &amp; Boekelheide, Inc.
------- Comment #6 From 2003-02-01 03:25:52 -------
Возможно, есть более правильный вариант.

<a href="http://altlinux.ru/pipermail/community/2003-January/070969.html">http://altlinux.ru/pipermail/community/2003-January/070969.html</a> :

I am pleased to announce that a new drop of the Savage driver, version
1.1.25t, is now available on my web site at
<a href="http://www.probo.com/timr/savage40.html">http://www.probo.com/timr/savage40.html</a>.

This drop contains fixes for the two most commonly reported problems with the
Savage driver: the hangs in the \&quot;blaster\&quot; and \&quot;critical\&quot; modules of
xscreensaver, and the hang in \&quot;xine\&quot;.  All of these are now gone.

In addition, this drop contains support for the \&quot;xgamma\&quot; XFree86 extension.
This allows you to use the \&quot;xgamma\&quot; tool at depth 24 to adjust the gamma ramp
of the chips DAC.

This drop also contains fixes for two long-standing but minor bugs, including
bad cursor colors at depth 8 on the ProSavages, and bad handling of tiled
color patterns.

I also updated s3switch to add the patch I\'ve handed out to many of you
separately, so that it assumes all devices are connected, instead of trying
to detect them.

The Linux/x86 binary was built on and for XFree86 4.2.0.  It will run
successfully in 4.1.0, if you supply the -ignoreABI switch to override the
version detection.

Both binary and source for both the driver and s3switch are on the web page.
I will be submitting a patch to XFree86 by the end of the week.

Thanks to all of you who submitted patches, bug reports, and general warm
thoughts.

--
- Tim Roberts, <a href="mailto:timr@probo.com" target="_new">timr@probo.com</a>
  Providenza &amp; Boekelheide, Inc.
------- Comment #7 From 2003-02-06 21:01:34 -------
Проверьте на XFree86-4.2.1.1-alt3 (Будут в Sisyphus как только соберуться)
------- Comment #8 From 2003-02-06 21:01:34 -------
Проверьте на XFree86-4.2.1.1-alt3 (Будут в Sisyphus как только соберуться)
------- Comment #9 From 2003-02-17 20:13:10 -------
fixed (XFree86-4.2.1.1-alt3)
------- Comment #10 From 2003-02-17 20:13:10 -------
fixed (XFree86-4.2.1.1-alt3)