Bug 11556 - pcmcia card up/down in profiles
: pcmcia card up/down in profiles
Status: CLOSED NOTABUG
: Sisyphus
(All bugs in Sisyphus/etcnet)
: unstable
: all Linux
: P2 blocker
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2007-04-18 13:57 by
Modified: 2007-04-18 21:20 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-04-18 13:57:57
аже если DISABLE=no и pcmcia карта подключена и линк есть, тогда
  skipping hotplug iface 'ext' SKIPPED
и ifdown/up ext не работает
Как включать выключать pcmcia карту руками и в профайле?

ext/options:

USE_HOTPLUG=yes
USE_PCMCIA=yes
TYPE=eth
MODULE=8390
BOOTPROTO=static
LINKDETECT=yes
DISABLED=no




Actual Results:  
# /etc/init.d/network restartwith home

Loading iptables data..............
Computing interface groups: ... 3 interfaces found
Processing /etc/net/vlantab: empty.
Stopping group 1/realphys (2 interfaces)
         Stopping ext:  skipping hotplug iface 'ext' SKIPPED
         Stopping int: ...OK
Stopping group 0/virtual (1 interfaces)
         Stopping lo:
Stopping iptables for lo
         Unloading rules for the "OUTPUT" chain in the "filter" table.
         Unloading rules for the "INPUT" chain in the "filter" table.
         .OK
Stopping iptables for default
         Flushing the "OUTPUT" chain in the "filter" table
         Flushing the "FORWARD" chain in the "filter" table
         Flushing the "INPUT" chain in the "filter" table
         Flushing the "POSTROUTING" chain in the "nat" table
         Flushing the "OUTPUT" chain in the "nat" table
         Flushing the "PREROUTING" chain in the "nat" table
         Flushing the "POSTROUTING" chain in the "mangle" table
         Flushing the "OUTPUT" chain in the "mangle" table
         Flushing the "FORWARD" chain in the "mangle" table
         Flushing the "INPUT" chain in the "mangle" table
         Flushing the "PREROUTING" chain in the "mangle" table
         Setting ACCEPT policy for the "INPUT" chain in the "filter" table
         Setting ACCEPT policy for the "FORWARD" chain in the "filter" table
         Setting ACCEPT policy for the "OUTPUT" chain in the "filter" table
Starting iptables for default
         Setting ACCEPT policy for the "INPUT" chain in the "filter" table
         Setting ACCEPT policy for the "FORWARD" chain in the "filter" table
         Setting ACCEPT policy for the "OUTPUT" chain in the "filter" table
Computing interface groups: ... 3 interfaces found
Starting group 0/virtual (1 interfaces)
         Starting lo: .....
Starting iptables for lo
         Loading rules for the "INPUT" chain in the "filter" table.
         Loading rules for the "OUTPUT" chain in the "filter" table.
         OK
Starting group 1/realphys (2 interfaces)
         Starting ext:  skipping hotplug iface 'ext' SKIPPED
         Starting int: .......OK
Processing /etc/net/vlantab: empty.
------- Comment #1 From 2007-04-18 20:32:16 -------
Боюсь, что состоянием hotplug/PCMCIA устройств мы не можем управлять с помощью
ifup и ifdown, а можем только предпринимать необходимые действия, реагируя на
фактическое появление или исчезновение устройства.
------- Comment #2 From 2007-04-18 21:04:06 -------
(In reply to comment #1)
> Боюсь, что состоянием hotplug/PCMCIA устройств мы не можем управлять с помощью
> ifup и ifdown, а можем только предпринимать необходимые действия, реагируя на
> фактическое появление или исчезновение устройства.

Дык у не надо управлять поднятием-опусканием драйвера.
Есть драйвер - сделали ip link ... set up, не подгружен - ни чего не делаем.
А иначе - раутами каша: по два default'а и др.
------- Comment #3 From 2007-04-18 21:12:40 -------
*** Bug 11555 has been marked as a duplicate of this bug. ***
------- Comment #4 From 2007-04-18 21:20:26 -------
*** Bug 9683 has been marked as a duplicate of this bug. ***