Bug 1188 - image maps do not work with the new graphviz
: image maps do not work with the new graphviz
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/doxygen)
: unstable
: all Linux
: P4 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2002-08-08 21:04 by
Modified: 2003-08-25 15:18 (History)


Attachments
0001188-doxygen-1.2.17-imaprect.patch (deleted)
2002-08-08 21:04, Sergey Vlasov
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2002-08-08 21:04:48
Image maps in the generated HTML documentation (graphical class hierarchy,
collaboration graphs, ...) do not work in doxygen-1.2.17-alt1 when used
together with graphviz-1.8.8-alt1.

The problem is caused by the change in graphviz:

April 19, 2002
        - Coords of rectangles changed to left/top right/bottom in -Timap.

Because of this, doxygen puts coordinates in reverse order, and the image maps
do not work.

The attached patch adds a check to put coordinates into the right order,
independent of the graphviz version.
---

---
------- Comment #1 From 2002-08-09 18:49:43 -------
Applied in doxygen-1.2.17-alt2.
------- Comment #2 From 2002-08-09 18:49:43 -------
Applied in doxygen-1.2.17-alt2.