Bug 1189 - image map regions do not match png output
: image map regions do not match png output
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/graphviz)
: unstable
: all Linux
: P4 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2002-08-08 21:21 by
Modified: 2005-07-13 15:45 (History)


Attachments
0001189-graphviz-1.8.8-imapmargin.patch (deleted)
2002-08-08 21:21, Sergey Vlasov
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2002-08-08 21:21:07
When graphviz-1.8.8-alt1 is used together with doxygen-1.2.17 (after fixing the
bug #0001188 in doxygen), the image map regions do not match the actual images
(the regions are shifted down and to the right).

The problem is that dotneato_write() [dotneato/common/output.c] sets non-zero
default margins for the drawing; dotneato/common/gdgen.c handles the margins,
but dotneato/common/imapgen.c does not.

The attached patch adds margin handling to imapgen.c (the appropriate code was
copied from gdgen.c). After applying this patch image maps in the
Doxygen-generated pages work correctly (the coordinates match with the actual
images).
---

---
------- Comment #1 From 2004-05-24 15:07:59 -------
на мантейнера 
 
------- Comment #2 From 2004-05-24 15:41:15 -------
to maintainer 
------- Comment #3 From 2004-05-25 16:07:41 -------
recheck please with latest package version
------- Comment #4 From 2004-06-05 17:12:38 -------
btw patch is zero length :)
------- Comment #5 From 2004-06-05 17:35:02 -------
Seems to be fixed in new version.