Bug 12058 - Выдает ошибку, если в sources.list расположение фалой не локальное
: Выдает ошибку, если в sources.list расположение фалой не локальное
Status: CLOSED DUPLICATE of bug 11739
: Sisyphus
(All bugs in Sisyphus/spt)
: unstable
: all Linux
: P2 critical
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2007-06-18 15:09 by
Modified: 2008-01-25 18:24 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-06-18 15:09:05
Пытаюсь собрать desktop такой коммандой:
$spt -v --arch=i586 --apt-config=/home/stanv/apt_dir_conf/apt.conf
--profile-dir=dvd4 .

Причем:
$ cat ~/apt_dir_conf/apt.conf 
Dir::Etc::SourceList "/home/stanv/apt_dir_conf/sources.list";
Dir::Etc::SourceParts "/var/empty";


[stanv@stanv desktop]$ cat ~/apt_dir_conf/sources.list 
rpm [alt] ftp://salto/branches/4.0 i586 classic
rpm-src [alt] ftp://salto/branches/4.0 i586 classic
rpm [alt] ftp://salto/branches/4.0 noarch classic
rpm ftp://ftp.altlinux.org/pub/people/boyarsh/repo i586 hasher other kernel

Все репозитории лежат удаленно на FTP.

После длительной работы, вот такое:
....
sent 715721182 bytes  received 786 bytes  21364834.87 bytes/sec
total size is 715631679  speedup is 1.00
spt: Making component rescue
spt: Making component live
spt: Making component install2
spt: Making component base
spt: Installation packages for hook
hsh-install: changed working directory to `/home/stanv/tmp/desktop'
mkdir: created directory `/home/stanv/tmp/desktop/lockdir'
Reading Package Lists... Done
Building Dependency Tree... Done
Selecting apt-utils.32bit for 'apt-utils'
Selecting rsync.32bit for 'rsync'
rsync.32bit is already the newest version.
The following extra packages will be installed:
  apt-conf-server.32bit apt-utils.32bit apt.32bit bzip2.32bit diffutils.32bit
  gnupg.32bit libapt.32bit libgcc4.1.32bit liblua5.1.32bit libstdc++4.1.32bit
  setproctitle.32bit
The following NEW packages will be installed:
  apt-conf-server.32bit apt-utils.32bit apt.32bit bzip2.32bit diffutils.32bit
gnupg.32bit libapt.32bit libgcc4.1.32bit liblua5.1.32bit libstdc++4.1.32bit
  setproctitle.32bit
0 upgraded, 11 newly installed, 0 removed and 0 not upgraded.
Need to get 3666kB of archives.
After unpacking 8682kB of additional disk space will be used.
Get:1 ftp://salto i586/classic libgcc4.1.32bit 4.1.1-alt11 [35.4kB]
Get:2 ftp://salto i586/classic liblua5.1.32bit 5.1.2-alt1 [87.3kB]
Get:3 ftp://salto i586/classic libstdc++4.1.32bit 4.1.1-alt11 [317kB]
Get:4 ftp://salto i586/classic libapt.32bit 0.5.15lorg2-alt11 [381kB]
Get:5 ftp://salto i586/classic apt-conf-server.32bit 4.0-alt2.M40.1 [12.1kB]
Get:6 ftp://salto i586/classic bzip2.32bit 1:1.0.4-alt3 [44.4kB]
Get:7 ftp://salto i586/classic gnupg.32bit 1.4.7-alt1 [1880kB]
Get:8 ftp://salto i586/classic setproctitle.32bit 0.3.1-alt1 [5222B]
Get:9 ftp://salto i586/classic apt.32bit 0.5.15lorg2-alt11 [546kB]
Get:10 ftp://salto i586/classic diffutils.32bit 2.8.7-alt3 [295kB]
Get:11 ftp://salto i586/classic apt-utils.32bit 0.5.15lorg2-alt11 [63.7kB]
Fetched 3666kB in 0s (8571kB/s)
Download complete and in download only mode
hsh-install: calculated package file list.
`/home/stanv/tmp/desktop/aptbox/var/cache/apt/archives/libgcc4.1.32bit_4.1.1-alt11_i586.rpm'
-> `chroot/.in/libgcc4.1.32bit_4.1.1-alt11_i586.rpm'
`/home/stanv/tmp/desktop/aptbox/var/cache/apt/archives/liblua5.1.32bit_5.1.2-alt1_i586.rpm'
-> `chroot/.in/liblua5.1.32bit_5.1.2-alt1_i586.rpm'
`/home/stanv/tmp/desktop/aptbox/var/cache/apt/archives/libstdc++4.1.32bit_4.1.1-alt11_i586.rpm'
-> `chroot/.in/libstdc++4.1.32bit_4.1.1-alt11_i586.rpm'
`/home/stanv/tmp/desktop/aptbox/var/cache/apt/archives/libapt.32bit_0.5.15lorg2-alt11_i586.rpm'
-> `chroot/.in/libapt.32bit_0.5.15lorg2-alt11_i586.rpm'
`/home/stanv/tmp/desktop/aptbox/var/cache/apt/archives/apt-conf-server.32bit_4.0-alt2.M40.1_i586.rpm'
-> `chroot/.in/apt-conf-server.32bit_4.0-alt2.M40.1_i586.rpm'
`/home/stanv/tmp/desktop/aptbox/var/cache/apt/archives/bzip2.32bit_1%3a1.0.4-alt3_i586.rpm'
-> `chroot/.in/bzip2.32bit_1%3a1.0.4-alt3_i586.rpm'
`/home/stanv/tmp/desktop/aptbox/var/cache/apt/archives/gnupg.32bit_1.4.7-alt1_i586.rpm'
-> `chroot/.in/gnupg.32bit_1.4.7-alt1_i586.rpm'
`/home/stanv/tmp/desktop/aptbox/var/cache/apt/archives/setproctitle.32bit_0.3.1-alt1_i586.rpm'
-> `chroot/.in/setproctitle.32bit_0.3.1-alt1_i586.rpm'
`/home/stanv/tmp/desktop/aptbox/var/cache/apt/archives/apt.32bit_0.5.15lorg2-alt11_i586.rpm'
-> `chroot/.in/apt.32bit_0.5.15lorg2-alt11_i586.rpm'
`/home/stanv/tmp/desktop/aptbox/var/cache/apt/archives/diffutils.32bit_2.8.7-alt3_i586.rpm'
-> `chroot/.in/diffutils.32bit_2.8.7-alt3_i586.rpm'
`/home/stanv/tmp/desktop/aptbox/var/cache/apt/archives/apt-utils.32bit_0.5.15lorg2-alt11_i586.rpm'
-> `chroot/.in/apt-utils.32bit_0.5.15lorg2-alt11_i586.rpm'
Preparing...                 ##################################################
libgcc4.1                    ##################################################
liblua5.1                    ##################################################
libstdc++4.1                 ##################################################
libapt                       ##################################################
apt-conf-server              ##################################################
bzip2                        ##################################################
gnupg                        ##################################################
setproctitle                 ##################################################
apt                          ##################################################
diffutils                    ##################################################
apt-utils                    ##################################################
hsh-install: Packages installation complete.
Preparing...                
############################################################
hsh-install: RPM database updated.
removed `/home/stanv/tmp/desktop/lockdir/pid'
removed directory: `/home/stanv/tmp/desktop/lockdir'
/usr/bin/spt-sh-functions: line 209: /apt-get: No such file or directory
spt: Fatal calculated package file list is not local and apt-get does not
support APT::Get::PrintLocalFile option.
spt: Fatal Failed to generate package file list.
Command exited with non-zero status 1

У boyarsh@altlinux.org доступ к репозитарием идет через file://
У меня же через ftp://
------- Comment #1 From 2007-06-19 00:22:24 -------

*** This bug has been marked as a duplicate of 11739 ***