Bug 12584 - --nochange option is not recognized
: --nochange option is not recognized
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/rpm-utils)
: unstable
: all Linux
: P2 minor
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2007-08-17 12:36 by
Modified: 2008-08-29 16:02 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-08-17 12:36:23
$ add_changelog --nochange share2me-node-base.spec
add_changelog: нераспознанный ключ `--nochange'
add_changelog - generates and adds changelog entry to rpm specfile.

add_changelog is free software, covered by the GNU General Public License.
add_changelog comes with ABSOLUTELY NO WARRANTY, see license for details.

Usage: add_changelog [options] <specfile> [ <specfile>]*

Valid options are:
-s STAMPER, --stamper=STAMPER           path to STAMPER;
-r RPM, --rpm=RPM                       path to RPM;
-a args, --args=args                    arguments for RPM;
-e entry, --entry=entry                 changelog entry text;
--nochange                              do not check specfile versions;
-h, --help                              show this text.

Default path to STAMPER is STAMPER;
Default path to RPM is /bin/rpm;
Default changelog entry is '- '.
igor@localhost modules/rpmbuild/node-base $ rpm -qf /usr/bin/add_changelog 
rpm-utils-0.9.5-alt1
------- Comment #1 From 2007-08-17 12:39:36 -------
Это опечатка, параметр называется --nocheck.
------- Comment #2 From 2007-08-17 13:04:59 -------
опечатка в встренном help, ok.
------- Comment #3 From 2007-09-14 03:27:27 -------
Fixed in 0.9.6-alt1-1-g2f0ff82
------- Comment #4 From 2007-09-14 12:14:15 -------
(In reply to comment #3)
> Fixed in 0.9.6-alt1-1-g2f0ff82

Баг специально не помечен как FIXED или случайно?
------- Comment #5 From 2007-09-19 01:48:17 -------
OK, пусть будет fixed, только внимание отвлекает.
------- Comment #6 From 2008-08-29 16:02:02 -------
*** Bug 13969 has been marked as a duplicate of this bug. ***