Bug 12768 - eject can't control specified drive speed
: eject can't control specified drive speed
Status: CLOSED WONTFIX
: Branch 4.0
(All bugs in Branch 4.0/eject)
: 4.0
: all Linux
: P2 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2007-09-13 20:49 by
Modified: 2014-11-05 20:14 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-09-13 20:49:18
ALD4, upgraded to Branch 4
IBM ThinkPad R40

# hdparm -i /dev/hdc

/dev/hdc:

 Model=HL-DT-STCD-RW/DVD DRIVE GCC-4240N, FwRev=0214, SerialNo=
 Config={ Fixed Removeable DTR<=5Mbs DTR>10Mbs nonMagnetic }
 RawCHS=0/0/0, TrkSize=0, SectSize=0, ECCbytes=0
 BuffType=unknown, BuffSize=0kB, MaxMultSect=0
 (maybe): CurCHS=0/0/0, CurSects=0, LBA=yes, LBAsects=0
 IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
 PIO modes:  pio0 pio1 pio2 pio3 pio4
 DMA modes:  sdma0 sdma1 sdma2 mdma0 mdma1 mdma2
 UDMA modes: udma0 udma1 *udma2
 AdvancedPM=no
 Drive conforms to: Unspecified:  ATA/ATAPI-2 ATA/ATAPI-3 ATA/ATAPI-4 ATA/ATAPI-5

 * signifies the current active mode

Notebook BIOS setting for the /dev/hdc: SILENT

$ eject -X /dev/hdc
4 10 16 20 24
---
Problem:

$ eject -X 4 /dev/hdc [/dev/cdrom] can't set specified drive speed, drive
continue at high speed.

# eject -X 4 /dev/hdc [/dev/cdrom] can't set specified drive speed, drive
continue at high speed.
Steps to Reproduce:
1.$ eject -X 4 /dev/hdc
2.$ eject -X 4 /dev/cdrom
3.the same from root
Actual Results:  
No drive speed change.

Expected Results:  
Set the drive speed according to input value (e.g. -X 4)
------- Comment #1 From 2008-01-25 17:12:00 -------
*** Bug 12769 has been marked as a duplicate of this bug. ***
------- Comment #2 From 2008-01-25 17:13:50 -------
Could you test cdctl with that drive?  It's in Sisyphus but should be binary
compatible (btw I'd post a transition-to-branch request).
------- Comment #3 From 2008-06-13 12:59:26 -------
*** This bug has been confirmed by popular vote. ***
------- Comment #4 From 2014-11-05 20:14:37 -------
В 4.0/branch исправления не будут вноситься уже технически (заглушена очередь
на сборку), поэтому прошу ошибки, актуальные для sisyphus/p7/t7, перевесить на
текущие ветки или сизиф.