Bug 13050 - не устанавливается по причине старого openexr
: не устанавливается по причине старого openexr
Status: CLOSED NOTABUG
: Branch 4.0
(All bugs in Branch 4.0/ImageMagick)
: 4.0
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2007-10-06 19:09 by
Modified: 2008-06-16 22:02 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-10-06 19:09:11
смотрелось на Server 4.0 + updates

# grep ^rpm -R /etc/apt/
/etc/apt/sources.list.d/server.alt.list:rpm [security]
ftp://ftp.altlinux.org/pub/distributions/ALTLinux/4.0/Server/current i586
main
/etc/apt/sources.list.d/server.alt.list:rpm [security]
ftp://ftp.altlinux.org/pub/distributions/ALTLinux/4.0/Server/current i586
classic
/etc/apt/sources.list.d/server.alt.list:rpm [updates]
ftp://updates.altlinux.org/4.0 i586 updates

# apt-get update
Get:1 ftp://ftp.altlinux.org i586 release [1016B]
Get:2 ftp://updates.altlinux.org i586 release [712B]
Fetched 1728B in 2s (792B/s)
Hit ftp://ftp.altlinux.org i586/main pkglist
Hit ftp://updates.altlinux.org i586/updates pkglist
Hit ftp://ftp.altlinux.org i586/main release
Hit ftp://updates.altlinux.org i586/updates release
Hit ftp://ftp.altlinux.org i586/classic pkglist
Hit ftp://ftp.altlinux.org i586/classic release
Reading Package Lists... Done
Building Dependency Tree... Done

# apt-get install ImageMagick
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  ImageMagick: Depends: libIlmImf.so.4 but it is not installable
E: Broken packages

при этом:

# apt-cache search libIlmImf
openexr - A high-dynamic-range image file library

# apt-get install openexr
# rpm -q --provides openexr | grep libIlmImf
libIlmImf.so.2
------- Comment #1 From 2007-10-07 18:49:00 -------
Дима, переложи пожалуйста ещё openexr из branch/4.0 в updates.

И всё, что на него зависит.
------- Comment #2 From 2007-10-07 22:19:01 -------
бррр...

я не знаю как и что, но после очередного
apt-get update
apt-get upgrade

он таки поставился... 

Ставить в INVALID?
------- Comment #3 From 2007-12-10 16:42:19 -------
Ставим
------- Comment #4 From 2008-06-16 22:02:27 -------
закрываем