Bug 13068 - Audacity crashes on some operations
: Audacity crashes on some operations
Status: CLOSED DUPLICATE of bug 11880
: Branch 4.0
(All bugs in Branch 4.0/audacity)
: 4.0
: all Linux
: P2 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2007-10-09 17:22 by
Modified: 2007-10-30 17:02 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-10-09 17:22:41
Here is what I get when starting audacity and trying to select analyze->"plot 
spectrum":

bash$ audacity 

(audacity:27154): Gdk-CRITICAL **: gdk_drawable_get_image: assertion 
`GDK_IS_DRAWABLE (drawable)' failed

(audacity:27154): Gdk-CRITICAL **: gdk_image_get_colormap: assertion 
`GDK_IS_IMAGE (image)' failed

(audacity:27154): GLib-GObject-CRITICAL **: g_object_unref: assertion 
`G_IS_OBJECT (object)' failed
The program 'audacity' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 12929342 error_code 11 request_code 53 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Just exitting audacity causes it to just segfault:

bash$ audacity 
Segmentation fault

Running audacity -test gives the following: 

Using 57260 blocks of 293 samples each, for a total of 32.0 MB.
Preparing...
Performing 100 edits...
Trial 0
Expected len 16777180, track len 10737278.
TEST FAILED!!!

What's up with the package and how can I help debugging it? 

(Отвечать можно по-русски :) )
Steps to Reproduce:
1.run audacity
2.close audacity
3.
Actual Results:  
Segmentation fault

Expected Results:  
Nothing ;)
------- Comment #1 From 2007-10-24 01:45:28 -------
Неожиданно выяснилось, что на "обычных" сорцах audacity, собранных с wxGTK2u-
2.6.4, эффект пропадает -- программа нормально запускается/останавливается и 
кажет частотную диаграмму (более детально пока не проверял). 

Можно ли иметь в системе два неконфликтующих набора wxGTK? 
------- Comment #2 From 2007-10-27 23:53:51 -------
Подтверждаю, поймано также на текущей сизифовой версии (тихий крэш на выходе).
------- Comment #3 From 2007-10-30 12:01:04 -------
audacity-1.3.4-alt0.1 пересобрана с wxGTK2u-2.6.4

*** This bug has been marked as a duplicate of 11880 ***