Bug 13267 - Не проигрывает ogg файлы размером меньше 7900 bytes
: Не проигрывает ogg файлы размером меньше 7900 bytes
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/gst-plugins-base)
: unstable
: all Linux
: P2 blocker
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2007-10-31 10:20 by
Modified: 2008-01-09 13:57 (History)


Attachments
Не играет (7.48 KB, application/octet-stream)
2007-10-31 10:22, Slava Dubrovskiy
no flags Details
Играет (8.25 KB, application/octet-stream)
2007-10-31 10:24, Slava Dubrovskiy
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-10-31 10:20:03
gst-launch не проигрывает маленькие файлы, размером приблизительно до 7900
байт.
Проверял на ogg файлах из пакета gcompris-voices-ru.
$ rpm -qa | grep gst-plugins
libgst-plugins-0.10.14-alt1
gst-plugins-oss-0.10.6-alt1
gst-plugins-base-audio-filters-0.10.14-alt1
gst-plugins-alsa-0.10.14-alt1
gst-plugins-vorbis-0.10.14-alt1
gst-plugins-base-0.10.14-alt1
gst-plugins-ogg-0.10.14-alt1
gcompris-gst-plugins-8.4.2-alt1
gst-plugins-good-0.10.6-alt1

[slava@dubrhost ~]$ gst-launch filesrc
location=/usr/share/gcompris/boards/voices/ru/misc/quit.ogg ! oggdemux !
vorbisdec ! audioconvert ! audioresample ! alsasink
Setting pipeline to PAUSED ...
Pipeline is PREROLLING ...
Pipeline is PREROLLED ...
Setting pipeline to PLAYING ...
New clock: GstAudioSinkClock
Got EOS from element "pipeline0".
Execution ended after 725567000 ns.
Setting pipeline to PAUSED ...
Setting pipeline to READY ...
Setting pipeline to NULL ...
FREEING pipeline ...

Это играет

[slava@dubrhost ~]$ gst-launch filesrc
location=/usr/share/gcompris/boards/voices/ru/misc/plus.ogg ! oggdemux !
vorbisdec ! audioconvert ! audioresample ! alsasink
Setting pipeline to PAUSED ...
Pipeline is PREROLLING ...

(gst-launch-0.10:21544): GStreamer-CRITICAL **: gst_event_new_new_segment_full:
assertion `start <= stop' failed
Pipeline is PREROLLED ...
Setting pipeline to PLAYING ...
New clock: GstAudioSinkClock
Got EOS from element "pipeline0".
Execution ended after 22239000 ns.
Setting pipeline to PAUSED ...
Setting pipeline to READY ...
Setting pipeline to NULL ...
FREEING pipeline ...

Это нет.

Из под xmms все файлы звук издают.
Steps to Reproduce:
1. apt-get install gcompris-voices-ru gcompris-gst-plugins
2. gst-launch filesrc
location=/usr/share/gcompris/boards/voices/ru/misc/plus.ogg ! oggdemux !
vorbisdec ! audioconvert ! audioresample ! alsasink
3.
------- Comment #1 From 2007-10-31 10:22:09 -------
Created an attachment (id=2244) [details]
Не играет
------- Comment #2 From 2007-10-31 10:24:20 -------
Created an attachment (id=2245) [details]
Играет
------- Comment #3 From 2007-10-31 10:28:37 -------
*** Bug 13265 has been marked as a duplicate of this bug. ***
------- Comment #4 From 2007-11-16 12:20:56 -------
http://bugzilla.gnome.org/show_bug.cgi?id=466717

I went on #gstreamer and got this anwser:
<__tim> bdoin: yes, fixed in the upcoming core/base 0.10.15 releases
(out tomorrow probably)
<thayta1> out in about an hour
------- Comment #5 From 2008-01-09 13:48:45 -------
Вообще-то, это не gstreamer, а gst-plugins-base. Перевесил.
------- Comment #6 From 2008-01-09 13:49:36 -------
fixed in gst-plugins-base-0.10.14-alt2.src.rpm
------- Comment #7 From 2008-01-09 13:57:34 -------
Спасибо