Bug 1346 - gcc bug #7808 - Compiler ignores cast from \'id<Protocol>\' to \'id\' or from \'id<Protocol1>\' to \'id<Protocol2
: gcc bug #7808 - Compiler ignores cast from \'id<Protocol>\' to \'id\' o...
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/gcc3.2-objc)
: unstable
: all Linux
: P4 major
Assigned To:
:
:
:
: 3093
:
  Show dependency tree
 
Reported: 2002-10-03 16:14 by
Modified: 2004-03-04 21:41 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2002-10-03 16:14:52
This is gcc bug #7808 (<a
href="http://gcc.gnu.org/cgi-bin/gnatsweb.pl?database=gcc">http://gcc.gnu.org/cgi-bin/gnatsweb.pl?database=gcc</a>)
reported and closed by Nicola Pero &lt;nicola AT brainstorm DOT co DOT uk&gt;

The compiler seems to be ignoring casts from \'id&lt;Protocol&gt;\'
to \'id\', and from \'id&lt;Protocol1&gt;\' to \'id&lt;Protocol2&gt;\'.

It\'s a regression: previous compilers (eg 2.95 and 2.91.66)
did the cast properly.
---

---
------- Comment #1 From 2003-09-25 08:32:24 -------
This bug fixed in upstream version 3.3 and test code from GCC's Bugzilla works
with mingw32-gcc-3.3-alt1 crosscompiler.

URL to GCC Bugzilla - http://gcc.gnu.org/bugzilla/show_bug.cgi?id=7808
------- Comment #2 From 2003-12-28 01:54:47 -------
Should be fixed in gcc3.3-objc-3.3.2-alt1