Bug 1354 - rsync-2.5.4-alt3 aborts with protocol error
: rsync-2.5.4-alt3 aborts with protocol error
Status: CLOSED WORKSFORME
: Sisyphus
(All bugs in Sisyphus/rsync)
: unstable
: all Linux
: P5 critical
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2002-10-04 21:30 by
Modified: 2003-11-14 15:41 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2002-10-04 21:30:42
rsync-2.5.4-alt3 on both ends.

<a href="mailto:vsu@canopus" target="_new">vsu@canopus</a> ~/cvs/claws-orig $ rsync -e ssh -avPzc --delete-after --stats 192.168.1.251:/home/vsu/cvs/claws-orig/sylpheed-claws/ sylpheed-claws/
receiving file list ... 
767 files to consider
rsync: connection unexpectedly closed (25607 bytes read so far)
rsync error: error in rsync protocol data stream (code 12) at io.c(151)

Repeating the command does not change anything.

Without the -c switch rsync succeeds:

<a href="mailto:vsu@canopus" target="_new">vsu@canopus</a> ~/cvs/claws-orig $ rsync -e ssh -avPz --delete-after --stats 192.168.1.251:/home/vsu/cvs/claws-orig/sylpheed-claws/ sylpheed-claws/ 
receiving file list ... 
767 files to consider
767 files to consider
rsync[26119] (receiver) heap statistics:
  arena:         205464   (bytes from sbrk)
  ordblks:           87   (chunks not in use)
  smblks:             0
  hblks:              0   (chunks from mmap)
  hblkhd:             0   (bytes from mmap)
  usmblks:            0
  fsmblks:            0
  uordblks:       88496   (bytes used)
  fordblks:      116968   (bytes free)
  keepcost:       11648   (bytes in releasable chunk)

Number of files: 767
Number of files transferred: 0
Total file size: 10161516 bytes
Total transferred file size: 0 bytes
Literal data: 0 bytes
Matched data: 0 bytes
File list size: 13323
Total bytes written: 16
Total bytes read: 13339

wrote 16 bytes  read 13339 bytes  1405.79 bytes/sec
total size is 10161516  speedup is 760.88

But repeating with -c gives the same error message.
---

---
I have saved both file trees in tar.bz2 (about 2M each), but it\'s inconvenient for me to send them through the web interface.
------- Comment #1 From 2002-10-07 19:35:39 -------
What\'s happening on the server side?
Is it reproducable also with rsync-2.5.5-alt2?
------- Comment #2 From 2002-10-07 19:35:39 -------
What\'s happening on the server side?
Is it reproducable also with rsync-2.5.5-alt2?
------- Comment #3 From 2003-01-29 18:35:00 -------
Can\'t reproduce this any longer even with that old version :-(
------- Comment #4 From 2003-01-29 18:35:00 -------
Can\'t reproduce this any longer even with that old version :-(
------- Comment #5 From 2003-02-03 18:33:47 -------
Unable to reproduce...
------- Comment #6 From 2003-02-03 18:33:47 -------
Unable to reproduce...