Bug 14065 - Иногда падает при выходе
: Иногда падает при выходе
Status: CLOSED WORKSFORME
: Sisyphus
(All bugs in Sisyphus/git-gui)
: unstable
: all Linux
: P2 minor
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2008-01-17 20:05 by
Modified: 2011-12-04 20:00 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-01-17 20:05:38
При закрытий окна git-gui (git-gui-1.5.3.8-alt1, например) наблюдаю иногда
такое:

~/git/grace$ git-gui                                                           

X Error of failed request:  RenderBadPicture (invalid Picture parameter)
  Major opcode of failed request:  155 (RENDER)
  Minor opcode of failed request:  7 (RenderFreePicture)
  Picture id in failed request: 0x2000189
  Serial number of failed request:  3727
  Current serial number in output stream:  3745
[1]    6248 exit 1     git-gui

С лучается не на всех репозиториях. Но воспроизводится постоянно.

Я конечно, понимаю, что коды возврата графических программ мало кто проверяет,
но поэтому и minor повесил - неаккуратненько.
------- Comment #1 From 2008-05-27 20:09:30 -------
(In reply to comment #0)
> При закрытий окна git-gui (git-gui-1.5.3.8-alt1, например) наблюдаю иногда такое:
> 
> ~/git/grace$ git-gui                                                           
>                                          
> X Error of failed request:  RenderBadPicture (invalid Picture parameter)
>   Major opcode of failed request:  155 (RENDER)
>   Minor opcode of failed request:  7 (RenderFreePicture)
>   Picture id in failed request: 0x2000189
>   Serial number of failed request:  3727
>   Current serial number in output stream:  3745
> [1]    6248 exit 1     git-gui

Это может быть баг в git-gui, а может быть баг в tk.
------- Comment #2 From 2008-05-27 20:25:22 -------
какой tk используется ?
------- Comment #3 From 2008-05-28 03:33:34 -------
~/git/grace$ R -qa G tk
tk-8.5.2-alt1
libtk-8.5.2-alt1

, воспроизводится на этом репо постоянно.
------- Comment #4 From 2011-01-22 15:19:40 -------
Воспроизводится на 
tk-8.5.7-alt1
git-1.6.5.2-alt2

Согласно http://osdir.com/ml/git/2009-07/msg00209.html

This is likely due to a bug in Tk, the widget toolkit of 'git gui'. The
bug was set to "obsolete" back in 2007, but there's no indication the
problem was fixed.

Там же:
You might like to raise this on the Tk bug tracker at sourceforge. On
my Ubuntu system I can reproduce this with Tk 8.5.7 but not with
8.4.19 nor the current HEAD (8.6b1.1).

Может, обновить Tk?
------- Comment #5 From 2011-01-22 18:13:04 -------
в сизифе tk 8.5.9, новее некуда.
------- Comment #6 From 2011-12-04 19:09:16 -------
Ныне воспроизводится?
------- Comment #7 From 2011-12-04 20:00:03 -------
Да как будто бы нет.