Bug 14248 - Не хватает зависимости от Java
: Не хватает зависимости от Java
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/runawfe-jboss)
: unstable
: all Linux
: P1 minor
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2008-01-30 13:34 by
Modified: 2008-06-13 15:02 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-01-30 13:34:24
Несмотря на очевидное использование JBoss'ом виртуальной машины Java
зависимость
на неё в пакете отсутствует. В идеале она должна бы ставиться автоматически, но
пока этого нет, нужна явная зависимость.
Исправить нужно очень быстро, Руна хочет, чтобы в начале февраля, уже был
выпущен пробный дистрибутив. Если нет времени, разрешите мне NMU.
------- Comment #1 From 2008-01-30 22:55:05 -------
Алексей!
NMU я выписал, но нужно ли его делать?

Необходимы пояснения, почему там нет зависимости.
советую перенести ее куда-то в другое место, 
например, профиль специализированного дистрибутива
или виртуальный пакет runawfe-<setup?>.

1)
Пока не дошлифованы альтернативы, выбор компилятора java в процессе сборки
осуществляется с помощью специальных пакетов jpackage-xx-compat.
поэтому указание Requires: java 
и Requires: java = 1.6.0
порушит сборку пакетов runawe
:(

2) Requires: java 
точнее,
Requires: java >= 1.5.0
(в сизифе и будущем 4.1) вытянет java-1.7.0-openjdk, которая альфа и
противопоказана.

3)
Requires: java = 1.5.0, безопасно, но тоже как-то не то. почему не 1.6.0?