Bug 14490 - Segfault при выходе из программы
: Segfault при выходе из программы
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/alterator-browser-qt)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2008-02-16 17:07 by
Modified: 2008-11-26 17:09 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-02-16 17:07:51
alterator-browser-qt-2.9.69-alt3

При закрытии программы в messages попадает

Feb 14 22:45:09 threebears kernel: alterator-brows[32613]: segfault at 00000034
eip 08078dce esp af8fc1c0 error 4
------- Comment #1 From 2008-02-18 16:15:21 -------
Как можно воспроизвести?
------- Comment #2 From 2008-02-18 23:47:26 -------
Подробности изложены тут:

http://lists.altlinux.org/pipermail/sisyphus/2008-February/212144.html
------- Comment #3 From 2008-02-19 14:46:49 -------
У меня не воспроизводится.
У вас воспроизводимо?
------- Comment #4 From 2008-02-20 00:03:46 -------
(In reply to comment #3)
> У меня не воспроизводится.
> У вас воспроизводимо?

Ага, причем черезвычайно надежно. Вот вывод в консоль:

[alexei@threebears ~]$ acc
socket path /tmp/.private/alexei/alterator/browser-sock ...
Sorry, you need to be root to run this binary.
Up akado
vbox, hbox, box widgets are deprecated. Use gridbox with colspan/rowspan attributes.
vbox, hbox, box widgets are deprecated. Use gridbox with colspan/rowspan attributes.
vbox, hbox, box widgets are deprecated. Use gridbox with colspan/rowspan attributes.
vbox, hbox, box widgets are deprecated. Use gridbox with colspan/rowspan attributes.
vbox, hbox, box widgets are deprecated. Use gridbox with colspan/rowspan attributes.


Вот в логах:
[root@threebears ~]# tail /var/log/messages | grep alter
Feb 20 00:01:08 threebears kernel: alterator-brows[8190]: segfault at fffffff8
eip 08078d71 esp afef70f0 error 4


На всякий случай: 

[root@threebears ~]# uname -r
2.6.24-wks-smp-alt1
------- Comment #5 From 2008-06-13 13:00:39 -------
*** This bug has been confirmed by popular vote. ***
------- Comment #6 From 2008-11-26 17:03:59 -------
*** Bug 17488 has been marked as a duplicate of this bug. ***
------- Comment #7 From 2008-11-26 17:09:00 -------
alterator-browser-qt-2.10.0-alt1