Bug 14562 - closes when keyboard layout is switched in shell prompt
: closes when keyboard layout is switched in shell prompt
Status: CLOSED WONTFIX
: Sisyphus
(All bugs in Sisyphus/Eterm)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2008-02-18 19:53 by
Modified: 2011-01-22 17:38 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-02-18 19:53:53
Eterm-0.9.3-alt2

bash-3.1.17-alt4
xorg-x11-server-1.3.0.0-alt13

I'm not sure this is really a bug of Eterm, will make more observations on other
terminals and then perhaps re-classify this report.

This bad behavior is very difficult to reproduce deterministically: it happens
often, but I can't reproduce it simply by pressing the same keys as in the case
when it happened. 

(If you experienced something similar, let's collect more data here!)

I use Capslock for switching the keyboard layout between Russian and English.
I do not use xxkb or any layout indicators.
Steps to Reproduce:
1. switch to Russian in another window
2. start typing something in Eterm while there is a bash prompt there (the last
time when it happened, I wanted to type "mount", I typed: ьщгте<ENTER>)
3. then I see that it's wrong, so I press Capslock (now there is a bash prompt
again, so I press Capslock when the line is empty, only the prompt)
Actual Results:  
The terminal disappears. 

bash seems not be crucial for this, it happened in apt-shell also. 
It seems that is is important that the line is empty when you press Capslock.

Expected Results:  
The terminal doesn't close unexpectedly.
------- Comment #1 From 2008-05-12 16:02:48 -------
So, I've been testing aterm for several months (aterm-1.0.1-alt2 now): this bug
is not a property of aterm. Now I'm starting to test xterm (xterm-235-alt1) for
this bug.
------- Comment #2 From 2011-01-22 17:38:29 -------
please try segfaulting more recent Eterm if it ever comes to Sisyphus again :)