Bug 14592 - displays garbage in the selection
: displays garbage in the selection
Status: CLOSED WORKSFORME
: Sisyphus
(All bugs in Sisyphus/evince)
: unstable
: all Linux
: P2 enhancement
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2008-02-20 21:56 by
Modified: 2010-09-28 18:06 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-02-20 21:56:05
evince-2.21.1-alt1
libpoppler-0.6.3-alt1
libcairo-1.4.10-alt1

Steps to Reproduce:
1. evince http://learn-gs.org/library/etc/1-4-whorf.pdf
2. select some words, for example, the tile: "THE RELATION"
3.
Actual Results:  
a sequence of "~" is seen in the selected region, no letters. 

("Internally", the selection works fine: you can test it by pasting the
selection to another application, you'll get the correct words.)

Expected Results:  
The letters are seen.
------- Comment #1 From 2008-02-21 16:57:54 -------
In some files, the letters are correctly displayed when selected: e.g.,
/usr/share/doc/wordnet/pdf/lexnames.5.pdf from wordnet-2.1-alt2.
------- Comment #2 From 2008-02-21 17:04:25 -------
Now I started to understand that this problem has no very good solution.
Probably, this is so in http://learn-gs.org/library/etc/1-4-whorf.pdf as it is
because it is a scanned paper (an image) with added words. So, there are no
fonts inside, so they can't be properly displayed.

So it's rather a feature request: in such cases not to show the "~"s instead of
the text but to show the selected text in a default font or to show the image
and indicate that a real text has been selected (say, by showing the selected
text in a "tooltip").
------- Comment #3 From 2010-09-27 17:13:13 -------
http://learn-gs.org/library/etc/1-4-whorf.pdf не доступен, не удается проверить
на новой версии evince
------- Comment #4 From 2010-09-28 18:06:28 -------
Приложите, пожалуйста, pdf'ку, на которой проявляется бага