Bug 14729 - alterator-net-wifi can not establish ad-hoc connection
: alterator-net-wifi can not establish ad-hoc connection
Status: NEW
: ALT Linux Desktop
(All bugs in ALT Linux Desktop/bugs)
: 4.0.2
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2008-03-01 18:38 by
Modified: 2008-06-13 13:00 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-03-01 18:38:20
Симптомы: настроил Wi-Fi Dlink RT73 на ndiswrapper
Вроде etc/net прописал.
Соединяюсь ad-hoc с ноутом (Вин ХР) и Альт Дектоп 4.0.2 Wi-Fi Dlink RT73 USB
(ndiswrapper) на  головном компе.
Сеть видят оба, но пакеты начинают ходить только после service network 
restart + желательно на ноуте тоже запустить "исправить" беспроводное 
подключение (как я понял, это аналог линуховой команды). После этого 
связь устанавливается, т.е. начинают ходить пакеты. ip оба static -
192.168.0.1 - Linux и 192.168.0.62 на винде.


Настройки в папке wlan0:
ipv4address:
192.168.0.1/24

ipv4route:


iwconfig:
essid Ivan_comp
mode 1
ap da:78:2b:ed:30:ea
channel 10
rate 54M

options:
TYPE=eth
MODULE=ndiswrapper
NEVER_RMMOD=YES
USE_HOTPLUG=no
ONBOOT=yes

wpa_supplicant.conf:
ctrl_interface=/var/run/wpa_supplicant
update_config=1

network={
         ssid="Ivan_comp"
         key_mgmt=NONE
}

после запуска компьютера огонек на ЮСБ "палочке" начинает мигать сериями
всполохов  с паузами. Второй огонек (пакеты) - потушен.

>>> Сеть видят оба, но пакеты начинают ходить только после
>>> > >> service network restart 
>> > > Если вообще никак -- ну... воткните эту команду в
>> > > /etc/rc.d/rc.local и сделайте его исполняемым  :( 

>> >> дать права на запуск?
> > 
> > Угу, или chmod +x /etc/rc.d/rc.local

Проблема решилась вставкой в этот файл трех строк:
/sbin/iwconfig wlan0 mode ad-hoc
/sbin/iwconfig wlan0 essid Ivan_comp
/sbin/iwconfig wlan0 ap da:78:2b:ed:30:ea

После этого все работает на "ура" без толкача.


Почему это не делает в моей случае сам etcnet - я так и не понял.
------- Comment #1 From 2008-06-13 13:00:03 -------
*** This bug has been confirmed by popular vote. ***