Bug 14841 - Обновить до 3.10.2
: Обновить до 3.10.2
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/ocaml)
: unstable
: all Linux
: P2 enhancement
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2008-03-10 10:57 by
Modified: 2008-04-24 09:34 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-03-10 10:57:54
Достаточно много изменений по сравнению с тем, что сейчас лежит в сизифе.
Я не в коей мере не ocaml-оист, но поглядев немного по сторонам, рискну
попросить разделить пакеты на runtime(*.cma, *.cmi)/devel(*.a, *.cmx, *.cmxa,
*.mli).

Steps to Reproduce:
1.
2.
3
------- Comment #1 From 2008-03-10 11:40:19 -------
По моему, ваше разделение "на runtime(*.cma, *.cmi)/devel(*.a, *.cmx, *.cmxa,
*.mli)" неверно.
------- Comment #2 From 2008-03-10 11:55:55 -------
Я не спорю, ибо не настолько компетентен в данном вопросе. 
Такое разделение было замечено мной в федоре.

У меня не получается собрать ocsigen, из-за того, что у нас осутствуют
*.a в ocaml-e. Конкретно в данном случае у меня проблемы с ocamlnet и
pcre-ocaml.
Мне ответили в рассылке, что (цитата)
"FYI: libnetsys.a contains compiled C bindings, and netsys.a contains 
compiled OCaml code." 

Научите как без "compiled C bindings" собрать пакет.

И еще - у нас ocaml пакеты именуются по разному. 
Имеет ли смысл привеcти названия пакетов к ocaml-* ?

Прошу прощения за несколько заданных вопросов здесь.
------- Comment #3 From 2008-03-21 14:43:44 -------
Кстати, 3.10.2 уже в Сизифе.