Bug 15130 - crashes on start
: crashes on start
Status: CLOSED WORKSFORME
: Sisyphus
(All bugs in Sisyphus/kpowersave)
: unstable
: all Linux
: P2 critical
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2008-03-27 23:41 by
Modified: 2008-05-07 22:59 (History)


Attachments
kpowersave.kcrash (2.73 KB, text/plain)
2008-03-27 23:44, Ivan Zakharyaschev
no flags Details
kpowersave.trace (566.59 KB, text/plain)
2008-03-27 23:46, Ivan Zakharyaschev
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-03-27 23:41:15
kpowersave-0.7.2-alt2

My powersaved doesn't really work (no speedstep module), but that's not
important: a program mustn't segfault.

I don't know whether it's the same bug as
https://bugzilla.altlinux.org/show_bug.cgi?id=11625 .
Steps to Reproduce:
[ivan@dell ~]$ sudo service powersaved status
acpid is stopped
powersaved is stopped
[ivan@dell ~]$ kpowersave
ERROR: Communication problem with kpowersave, it probably crashed.
[ivan@dell ~]$ KCrash: Application 'kpowersave' crashing...

[ivan@dell ~]$ sudo service powersaved start 
Starting acpid service:                                                        
                                                                               
   [ DONE ]
Starting powersaved service:                                                   
                                                                               
   [ DONE ]
[ivan@dell ~]$ sudo service powersaved status
acpid is running
powersaved is running
[ivan@dell ~]$ kpowersave
ERROR: Communication problem with kpowersave, it probably crashed.
[ivan@dell ~]$ KCrash: Application 'kpowersave' crashing...

[ivan@dell ~]$
------- Comment #1 From 2008-03-27 23:44:21 -------
Created an attachment (id=2525) [details]
kpowersave.kcrash

The backtrace by KCrash.
------- Comment #2 From 2008-03-27 23:46:33 -------
Created an attachment (id=2526) [details]
kpowersave.trace

The result of: strace -e trace=all -fF kpowersave &> kpowersave.trace
------- Comment #3 From 2008-03-27 23:48:25 -------
The similar bug I found is https://bugzilla.altlinux.org/show_bug.cgi?id=10803 ,
not 11625 .
------- Comment #4 From 2008-03-29 17:07:14 -------
Why no speedstep module? If 2.6.24 - try acpi-cpufreq
------- Comment #5 From 2008-03-29 17:09:51 -------
Проверьте на новой версии.
------- Comment #6 From 2008-03-31 21:41:51 -------
(In reply to comment #4)
> Why no speedstep module? If 2.6.24 - try acpi-cpufreq

Actually, it's OK, yes, acpi-cpufreq works fine. It was my fault in
understanding: I simply didn't understand that it works because some daemon used
to always bring the CPU back to the highest frequency. Now I turned it off.
------- Comment #7 From 2008-03-31 21:58:41 -------
(In reply to comment #5)
> Проверьте на новой версии.

kpowersave-0.7.3-alt1 не падает.