Bug 153 - rpm-4.0.3-alt0.5 cannot build kernel24-2.4.13-alt1
: rpm-4.0.3-alt0.5 cannot build kernel24-2.4.13-alt1
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/rpm)
: unstable
: all Linux
: P4 blocker
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2001-11-12 20:03 by
Modified: 2003-08-25 15:18 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2001-11-12 20:03:58
$ LC_ALL=C rpmbuild -bE kernel-2.4.spec >kernel-2.4.spec.out
error: parse error in expression
error: /home/vsu/RPM/SPECS/kernel-2.4.spec:1791: parseExpressionBoolean returns -1
$ rpm -qa |grep rpm-
rpm-build-4.0.3-alt0.5
librpm-4.0.3-alt0.5
librpm-devel-4.0.3-alt0.5
rpm-4.0.3-alt0.5

Аналогичная ситуация при -bb, -ba, ...

Вылетает на участке (строка с ошибкой помечена >>>):

BuildSecureSMP () {
	MakeVars smp-secure
%if %BUILD_SECURE_SMP
	BuildKernel
>>>%if %BUILD_DRM
	BuildDRM
%endif
	BuildDXR2
	BuildPCMCIA

---

---

------- Comment #1 From 2001-11-16 17:43:29 -------
Fixed in 4.0.3-alt0.6
------- Comment #2 From 2001-11-16 17:43:29 -------
Fixed in 4.0.3-alt0.6