Bug 1531 - unjustified PreReq: xemacs
: unjustified PreReq: xemacs
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/xemacs-fsf-compat)
: unstable
: all Linux
: P5 minor
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2002-11-07 23:23 by
Modified: 2003-08-25 15:18 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2002-11-07 23:23:18
xemacs-fsf-compat pkg has a

PreReq: xemacs

which IMHO is not correct since it doesn\'t use xemacs in (un)install-time scripts. In this situation, Requires would  be enough. 

This make apt-0.5 fail on a command like:

apt-get install xemacs-mule

because of a PreDepend-loop.

---

---
Other xemacs-* packages may have the same problem. I had a quick look through their install-time scripts: the use /usr/share/info/xemacs/dir, so they need only a PreReq on xemacsen, not on xemacs.

------- Comment #1 From 2002-12-23 13:19:38 -------
fixed in xemacs-fsf-compat-1.11-alt2
------- Comment #2 From 2002-12-23 13:19:38 -------
fixed in xemacs-fsf-compat-1.11-alt2
------- Comment #3 From 2003-01-09 12:58:27 -------
fixed in xemacs-fsf-compat-1.11-alt2
------- Comment #4 From 2003-01-09 12:58:27 -------
fixed in xemacs-fsf-compat-1.11-alt2