Bug 1583 - perl mandates some perl-* packages
: perl mandates some perl-* packages
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/perl)
: unstable
: all Linux
: P5 enhancement
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2002-11-20 04:45 by
Modified: 2003-09-24 12:29 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2002-11-20 04:45:59
On an upgrade I get:

	perl(Storable.pm)   is needed by perl-5.8.0-alt0.8.1
	perl(Term/ReadKey.pm)   is needed by perl-5.8.0-alt0.8.1
	perl(Text/Balanced.pm)   is needed by perl-5.8.0-alt0.8.1

Results for an uninformed observer:
1. \"Complete\" perl requires some 3 packages representing perl modules, which is strange. The perl bundle doesn\'t
depend on any third-party Perl modules, does it?
2. Only one of these packages is also required by some application packages, one of the dependants being small and important enough to justify it independance from the \"complete\" perl.
3. These packages do not seem to require anything other than core Perl and glibc.

Might it be useful to incorporate these modules into the perl package, since they are apparently included in the perl bundle? I doubt they will be updated in CPAN independently of the bundle, and in this case, they can get into the mother package as additional sources. Storable.pm, required by foomatic-addon, is cool and lean enough to be included in perl-base.
---

---

------- Comment #1 From 2003-08-24 20:44:20 -------
Reassigning to AT. Close if you don't find it a problem.
------- Comment #2 From 2003-09-22 14:54:10 -------
No perl binary package since May 26 2003. :)
------- Comment #3 From 2003-09-24 12:29:32 -------
Okay, okay :)